summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-04 20:39:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-07 14:12:16 +0200
commita4718a505b18fd3eba4cc4468468371ff75ccc5c (patch)
treea09522986c700c02f002d3b60b1256c8bba9ee67 /media-sound/brutefir/brutefir-1.0k-r2.ebuild
parentmedia-sound/id3v2: add EAPI7 ebuild (diff)
downloadgentoo-a4718a505b18fd3eba4cc4468468371ff75ccc5c.tar.gz
gentoo-a4718a505b18fd3eba4cc4468468371ff75ccc5c.tar.bz2
gentoo-a4718a505b18fd3eba4cc4468468371ff75ccc5c.zip
media-sound/brutefir: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/665238 Closes: https://github.com/gentoo/gentoo/pull/9779
Diffstat (limited to 'media-sound/brutefir/brutefir-1.0k-r2.ebuild')
-rw-r--r--media-sound/brutefir/brutefir-1.0k-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/brutefir/brutefir-1.0k-r2.ebuild b/media-sound/brutefir/brutefir-1.0k-r2.ebuild
new file mode 100644
index 000000000000..c4bc957fd6f7
--- /dev/null
+++ b/media-sound/brutefir/brutefir-1.0k-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Software convolution engine for applying long FIR filters"
+HOMEPAGE="https://www.ludd.ltu.se/~torger/brutefir.html"
+SRC_URI="https://www.ludd.ltu.se/~torger/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ld.patch )
+
+src_compile() {
+ tc-export AS CC
+ emake
+}
+
+src_install() {
+ emake LIBDIR="/usr/$(get_libdir)" DESTDIR="${D}" \
+ install
+ dodoc CHANGES README
+
+ insinto /usr/share/${PN}
+ doins xtc_config directpath.txt crosspath.txt massive_config \
+ bench1_config bench2_config bench3_config bench4_config \
+ bench5_config
+}
+
+pkg_postinst() {
+ elog "Brutefir is a complicated piece of software. Please"
+ elog "read the documentation first! You can find"
+ elog "documentation here: http://www.ludd.luth.se/~torger/brutefir.html"
+ elog "Example config files are in /usr/share/brutefir"
+}