summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/christine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/christine')
-rw-r--r--media-sound/christine/Manifest1
-rw-r--r--media-sound/christine/christine-0.7.0.ebuild50
-rw-r--r--media-sound/christine/files/christine-0.7.0-validate.patch33
-rw-r--r--media-sound/christine/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/media-sound/christine/Manifest b/media-sound/christine/Manifest
new file mode 100644
index 000000000000..e420355d2c36
--- /dev/null
+++ b/media-sound/christine/Manifest
@@ -0,0 +1 @@
+DIST christine-0.7.0.tar.bz2 421633 SHA256 de146b950b73692361ff3fcb8122ed2445d5aae07ad6a016117548bfbfe24660
diff --git a/media-sound/christine/christine-0.7.0.ebuild b/media-sound/christine/christine-0.7.0.ebuild
new file mode 100644
index 000000000000..d4e1cb825f3f
--- /dev/null
+++ b/media-sound/christine/christine-0.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+PYTHON_USE_WITH="sqlite"
+
+inherit autotools eutils python
+
+DESCRIPTION="A simple gstreamer based media player"
+HOMEPAGE="http://christine-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify nls readline"
+
+COMMON_DEPEND="=dev-python/gst-python-0.10*
+ dev-python/pycairo
+ dev-python/pygobject:2
+ =dev-python/pygtk-2*
+ media-libs/mutagen
+ libnotify? ( dev-python/notify-python )
+ readline? ( sys-libs/readline )"
+RDEPEND="${COMMON_DEPEND}
+ =media-plugins/gst-plugins-meta-0.10*"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-validate.patch
+ find . -name 'Makefile.*' -exec sed -i -e 's:mkdir_p:MKDIR_P:g' {} + #423113
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls) $(use_with readline)
+}
+
+pkg_postinst() { python_mod_optimize libchristine; }
+pkg_postrm() { python_mod_cleanup libchristine; }
diff --git a/media-sound/christine/files/christine-0.7.0-validate.patch b/media-sound/christine/files/christine-0.7.0-validate.patch
new file mode 100644
index 000000000000..76d5b146c345
--- /dev/null
+++ b/media-sound/christine/files/christine-0.7.0-validate.patch
@@ -0,0 +1,33 @@
+error: value "0.7.0" for key "Version" in group "Desktop Entry" is not a known version
+warning: key "Encoding" in group "Desktop Entry" is deprecated
+error: value "GTK;Application;AudioVideo" for string list key "Categories" in group "Desktop Entry" does not have a semicolon (';') as trailing character
+error: value "application/x-ogg;application/ogg;audio/x-mp3;audio/x-scpls;audio/x-mp3;audio/x-mpeg;audio/mpeg;audio/x-mpegurl;application/x-flac;video/mpeg;video/x-avi;video/x-ms-wmv;video/quicktime;video/x-ms-asf;video/x-msvideo" for string list key "MimeType" in group "Desktop Entry" does not have a semicolon (';') as trailing character
+
+--- christine.desktop.in
++++ christine.desktop.in
+@@ -6,10 +6,8 @@
+ TryExec=@programname@
+ Terminal=false
+ Type=Application
+-Version=@VERSION@
+-Encoding=UTF-8
+-Categories=GTK;Application;AudioVideo
+-MimeType=application/x-ogg;application/ogg;audio/x-mp3;audio/x-scpls;audio/x-mp3;audio/x-mpeg;audio/mpeg;audio/x-mpegurl;application/x-flac;video/mpeg;video/x-avi;video/x-ms-wmv;video/quicktime;video/x-ms-asf;video/x-msvideo
++Categories=GTK;AudioVideo;
++MimeType=application/x-ogg;application/ogg;audio/x-mp3;audio/x-scpls;audio/x-mpeg;audio/mpeg;audio/x-mpegurl;application/x-flac;video/mpeg;video/x-avi;video/x-ms-wmv;video/quicktime;video/x-ms-asf;video/x-msvideo;
+ StartupNotify=true
+ Name[es]=Reproductor Multimedia Christine
+-Comment[es]= Reproductor multimedia basado en gstreamer
++Comment[es]=Reproductor multimedia basado en gstreamer
+--- Makefile.am
++++ Makefile.am
+@@ -53,8 +53,7 @@
+ -e 's,@datadir\@,$(pkgdatadir),g' \
+ -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@sysconfdir\@,$(pkgsysconfdir),g' \
+- -e 's,@programname\@,$(PROGRAM_NAME),g' \
+- -e 's,@VERSION\@,$(VERSION),g'
++ -e 's,@programname\@,$(PROGRAM_NAME),g'
+
+ clean-local:
+ rm -rf christine.desktop
diff --git a/media-sound/christine/metadata.xml b/media-sound/christine/metadata.xml
new file mode 100644
index 000000000000..a5fef3064c61
--- /dev/null
+++ b/media-sound/christine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">christine</remote-id>
+ </upstream>
+</pkgmetadata>