summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-16 12:26:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-16 12:55:29 +0100
commit130fcc9f7be9fea0b9e72f551510be27b3232d32 (patch)
tree73298946d2ae15dd6fbe30bf6e5eb63b88a214f2 /media-sound/clementine/clementine-9999.ebuild
parentapp-office/libreoffice-l10n: amd64 stable wrt bug #647186 (diff)
downloadgentoo-130fcc9f7be9fea0b9e72f551510be27b3232d32.tar.gz
gentoo-130fcc9f7be9fea0b9e72f551510be27b3232d32.tar.bz2
gentoo-130fcc9f7be9fea0b9e72f551510be27b3232d32.zip
media-sound/clementine: Consolidate 9999-specifics
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound/clementine/clementine-9999.ebuild')
-rw-r--r--media-sound/clementine/clementine-9999.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index c80ccee1bf4a..caae648812d0 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -3,23 +3,26 @@
EAPI=6
-EGIT_BRANCH="qt5"
-EGIT_REPO_URI="https://github.com/clementine-player/Clementine.git"
-
PLOCALES="af ar be bg bn br bs ca cs cy da de el en en_CA en_GB eo es et eu fa fi fr ga gl he he_IL hi hr hu hy ia id is it ja ka kk ko lt lv mk_MK mr ms my nb nl oc pa pl pt pt_BR ro ru si_LK sk sl sr sr@latin sv te tr tr_TR uk uz vi zh_CN zh_TW"
-inherit cmake-utils flag-o-matic gnome2-utils l10n virtualx xdg-utils
-[[ ${PV} == *9999* ]] && inherit git-r3
+MY_P="${P/_}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_BRANCH="qt5"
+ EGIT_REPO_URI="https://github.com/clementine-player/Clementine.git"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="https://github.com/clementine-player/Clementine/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P^}"
+fi
+inherit cmake-utils flag-o-matic gnome2-utils l10n virtualx xdg-utils ${GIT_ECLASS}
+unset GIT_ECLASS
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
-[[ ${PV} == *9999* ]] || \
-SRC_URI="https://github.com/clementine-player/Clementine/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-[[ ${PV} == *9999* ]] || \
-KEYWORDS="~amd64 ~x86"
IUSE="box cdda +dbus debug dropbox googledrive ipod lastfm mms moodbar mtp projectm pulseaudio seafile skydrive test +udisks wiimote"
REQUIRED_USE="
@@ -99,10 +102,6 @@ DEPEND="${COMMON_DEPEND}
DOCS=( Changelog README.md )
-MY_P="${P/_}"
-[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${MY_P^}"
-
PATCHES=( "${FILESDIR}"/${PN}-fts3-tokenizer.patch )
src_prepare() {