summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/clementine/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/clementine/files')
-rw-r--r--media-sound/clementine/files/clementine-1.2.2-fix-build.patch25
-rw-r--r--media-sound/clementine/files/clementine-1.2.2-fix-build2.patch38
-rw-r--r--media-sound/clementine/files/clementine-1.2.2-gcc49.patch17
-rw-r--r--media-sound/clementine/files/clementine-1.2.3-namespaces.patch36
4 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/clementine/files/clementine-1.2.2-fix-build.patch b/media-sound/clementine/files/clementine-1.2.2-fix-build.patch
new file mode 100644
index 000000000000..7a83e3102b6b
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.2.2-fix-build.patch
@@ -0,0 +1,25 @@
+From 3df3a5b645737603af6bda844db04c431b9c8064 Mon Sep 17 00:00:00 2001
+From: John Maguire <john.maguire@gmail.com>
+Date: Thu, 6 Feb 2014 19:03:10 +0100
+Subject: [PATCH] Add missing header for syscall().
+
+This is cunningly not defined in syscall.h
+---
+ src/core/utilities.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/core/utilities.cpp b/src/core/utilities.cpp
+index 6fce753..cb9a94d 100644
+--- a/src/core/utilities.cpp
++++ b/src/core/utilities.cpp
+@@ -52,6 +52,7 @@
+ #endif
+
+ #ifdef Q_OS_LINUX
++# include <unistd.h>
+ # include <sys/syscall.h>
+ #endif
+ #ifdef Q_OS_DARWIN
+--
+1.8.5.5
+
diff --git a/media-sound/clementine/files/clementine-1.2.2-fix-build2.patch b/media-sound/clementine/files/clementine-1.2.2-fix-build2.patch
new file mode 100644
index 000000000000..05ec92f3c503
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.2.2-fix-build2.patch
@@ -0,0 +1,38 @@
+From 7671108aa8d02658cd35cacf4337507cc80ea03a Mon Sep 17 00:00:00 2001
+From: John Maguire <john.maguire@gmail.com>
+Date: Thu, 6 Feb 2014 19:46:08 +0100
+Subject: [PATCH] Add missing include for symlink()
+
+---
+ src/internet/spotifyblobdownloader.cpp | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/src/internet/spotifyblobdownloader.cpp b/src/internet/spotifyblobdownloader.cpp
+index 9827d65..5bd12a0 100644
+--- a/src/internet/spotifyblobdownloader.cpp
++++ b/src/internet/spotifyblobdownloader.cpp
+@@ -15,8 +15,9 @@
+ along with Clementine. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+-#include "config.h"
+ #include "spotifyblobdownloader.h"
++
++#include "config.h"
+ #include "spotifyservice.h"
+ #include "core/logging.h"
+ #include "core/network.h"
+@@ -32,6 +33,10 @@
+ #include <QtCrypto>
+ #endif // HAVE_QCA
+
++#ifdef Q_OS_UNIX
++ #include <unistd.h>
++#endif
++
+ const char* SpotifyBlobDownloader::kSignatureSuffix = ".sha1";
+
+
+--
+1.8.5.5
+
diff --git a/media-sound/clementine/files/clementine-1.2.2-gcc49.patch b/media-sound/clementine/files/clementine-1.2.2-gcc49.patch
new file mode 100644
index 000000000000..119298787a55
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.2.2-gcc49.patch
@@ -0,0 +1,17 @@
+In file included from ../../Clementine-1.2.2/src/core/mergedproxymodel.cpp:18:0:
+../../Clementine-1.2.2/src/core/mergedproxymodel.h:23:12: error: 'std::placeholders' has not been declared
+ using std::placeholders::_1;
+../../Clementine-1.2.2/src/core/mergedproxymodel.h:24:12: error: 'std::placeholders' has not been declared
+ using std::placeholders::_2;
+
+
+--- a/src/core/mergedproxymodel.h
++++ b/src/core/mergedproxymodel.h
+@@ -19,6 +19,7 @@
+ #define MERGEDPROXYMODEL_H
+
+ #include <QAbstractProxyModel>
++#include <functional>
+
+ using std::placeholders::_1;
+ using std::placeholders::_2;
diff --git a/media-sound/clementine/files/clementine-1.2.3-namespaces.patch b/media-sound/clementine/files/clementine-1.2.3-namespaces.patch
new file mode 100644
index 000000000000..2240debd0e4a
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.2.3-namespaces.patch
@@ -0,0 +1,36 @@
+From ec580cb815c16ec1ab43a469d5af7d51d8d03082 Mon Sep 17 00:00:00 2001
+From: Chocobozzz <florian.chocobo@gmail.com>
+Date: Wed, 16 Jul 2014 15:57:25 +0200
+Subject: [PATCH] No namespaces for DBus interfaces. Fixes #4401
+
+---
+ src/CMakeLists.txt | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 650fa74..775b0a5 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -892,11 +892,6 @@ optional_source(LINUX SOURCES widgets/osd_x11.cpp)
+ if(HAVE_DBUS)
+ file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/dbus)
+
+- # Hack to get it to generate interfaces without namespaces - required
+- # because otherwise org::freedesktop::UDisks and
+- # org::freedesktop::UDisks::Device conflict.
+- list(APPEND QT_DBUSXML2CPP_EXECUTABLE -N)
+-
+ # MPRIS DBUS interfaces
+ qt4_add_dbus_adaptor(SOURCES
+ dbus/org.freedesktop.MediaPlayer.player.xml
+@@ -964,6 +959,10 @@ if(HAVE_DBUS)
+
+ # DeviceKit DBUS interfaces
+ if(HAVE_DEVICEKIT)
++ set_source_files_properties(dbus/org.freedesktop.UDisks.xml
++ PROPERTIES NO_NAMESPACE dbus/udisks)
++ set_source_files_properties(dbus/org.freedesktop.UDisks.Device.xml
++ PROPERTIES NO_NAMESPACE dbus/udisksdevice)
+ qt4_add_dbus_interface(SOURCES
+ dbus/org.freedesktop.UDisks.xml
+ dbus/udisks)