summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-21 22:43:08 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-21 22:45:13 -0400
commit1b7e927fd05e7ecaf567d02ef3eee51056cafc88 (patch)
treebf98172b0e03bd8bc62430c62c61a55b15655e37 /media-sound/cmusfm/cmusfm-0.3.1.ebuild
parentapp-backup/duplicity: version bump to 0.7.10 (diff)
downloadgentoo-1b7e927fd05e7ecaf567d02ef3eee51056cafc88.tar.gz
gentoo-1b7e927fd05e7ecaf567d02ef3eee51056cafc88.tar.bz2
gentoo-1b7e927fd05e7ecaf567d02ef3eee51056cafc88.zip
media-sound/cmusfm: version bump to 0.3.1
Diffstat (limited to 'media-sound/cmusfm/cmusfm-0.3.1.ebuild')
-rw-r--r--media-sound/cmusfm/cmusfm-0.3.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/cmusfm/cmusfm-0.3.1.ebuild b/media-sound/cmusfm/cmusfm-0.3.1.ebuild
new file mode 100644
index 000000000000..a33443717dcd
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+CDEPEND="net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ media-sound/cmus"
+
+src_prepare() {
+ default
+ eautoreconf
+ DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}