summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-19 11:18:24 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-19 11:18:24 +0100
commit2429f959d860fb67ccb25035a32b28de3153e100 (patch)
treee95b591c276fe266e0b30357081360f447c7d70f /media-sound/codecgraph/codecgraph-20120114-r2.ebuild
parentmedia-sound/ifp-gnome: Add missing Python variables (diff)
downloadgentoo-2429f959d860fb67ccb25035a32b28de3153e100.tar.gz
gentoo-2429f959d860fb67ccb25035a32b28de3153e100.tar.bz2
gentoo-2429f959d860fb67ccb25035a32b28de3153e100.zip
media-sound/codecgraph: Add missing Python variables
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-sound/codecgraph/codecgraph-20120114-r2.ebuild')
-rw-r--r--media-sound/codecgraph/codecgraph-20120114-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/codecgraph/codecgraph-20120114-r2.ebuild b/media-sound/codecgraph/codecgraph-20120114-r2.ebuild
new file mode 100644
index 000000000000..799e395e9eb5
--- /dev/null
+++ b/media-sound/codecgraph/codecgraph-20120114-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Generates a graph based on the ALSA description of an HD Audio codec"
+HOMEPAGE="http://helllabs.org/codecgraph/"
+SRC_URI="http://helllabs.org/codecgraph/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ media-gfx/imagemagick"
+
+PATCHES=( "${FILESDIR}/${PV}-makefile-prefix.diff" )
+
+src_configure() {
+ python_fix_shebang *.py
+}
+
+src_install() {
+ default
+ dodoc codecs.txt IDEAS
+}