summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-06 22:06:25 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-06 22:13:29 -0400
commit2adc2485e705ba9921d40f4ff7bd76cc509dd8f1 (patch)
tree34a23cc8836d1a082928d72eeac37b0f2fe7a2ae /media-sound/csound/files
parentmedia-sound/csound: version bump to 6.07.0 (diff)
downloadgentoo-2adc2485e705ba9921d40f4ff7bd76cc509dd8f1.tar.gz
gentoo-2adc2485e705ba9921d40f4ff7bd76cc509dd8f1.tar.bz2
gentoo-2adc2485e705ba9921d40f4ff7bd76cc509dd8f1.zip
media-sound/csound: remove old
Diffstat (limited to 'media-sound/csound/files')
-rw-r--r--media-sound/csound/files/csound-6.05-underlinking.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/media-sound/csound/files/csound-6.05-underlinking.patch b/media-sound/csound/files/csound-6.05-underlinking.patch
deleted file mode 100644
index eac83f214190..000000000000
--- a/media-sound/csound/files/csound-6.05-underlinking.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-commit a4b1930b506274e328ee26cd6287965cb496062b
-Author: Steven Yi <stevenyi@gmail.com>
-Date: Mon Sep 28 18:21:22 2015 -0400
-
- modified make_utility and targets for csound-bin and mixer-bin to use add libm for linking when on Linux [fixes #526]
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2b16079..18a6ad1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -97,6 +97,10 @@ endfunction(make_executable)
- function(make_utility name srcs)
- make_executable(${name} "${srcs}" "${CSOUNDLIB}")
- add_dependencies(${name} ${CSOUNDLIB})
-+
-+ if(LINUX)
-+ target_link_libraries(${name} m)
-+ endif()
- endfunction()
-
-
-diff --git a/frontends/CMakeLists.txt b/frontends/CMakeLists.txt
-index d0e3a21..b31f37a 100644
---- a/frontends/CMakeLists.txt
-+++ b/frontends/CMakeLists.txt
-@@ -43,6 +43,9 @@ endfunction(make_plugin_frontend)
-
- # We need a different name to avoid clashes with float libcsound
- make_executable(csound-bin "${CS_MAIN_SRCS}" "${CSOUNDLIB}" csound)
-+if(LINUX)
-+ target_link_libraries(csound-bin m)
-+endif()
-
- message(STATUS "Building csLadspa")
-
-diff --git a/util/CMakeLists.txt b/util/CMakeLists.txt
-index 25089cc..ebf0aa5 100644
---- a/util/CMakeLists.txt
-+++ b/util/CMakeLists.txt
-@@ -23,9 +23,11 @@ if(BUILD_UTILITIES)
- make_utility(hetro het_main.c)
- make_utility(lpanal lpc_main.c)
- make_utility(lpc_export lpcx_main.c)
-- target_link_libraries(lpc_export m)
- make_utility(lpc_import lpci_main.c)
-- make_executable(mixer-bin mixer_main.c "${CSOUNDLIB}" mixer)
-+ if(LINUX)
-+ make_executable(mixer-bin mixer_main.c "${CSOUNDLIB}" mixer)
-+ endif()
-+ target_link_libraries(mixer-bin m)
- make_utility(pvanal pvc_main.c)
- make_utility(pvlook pvl_main.c)
- make_utility(pv_export pvx_main.c)