summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/darksnow/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/darksnow/files')
-rw-r--r--media-sound/darksnow/files/darksnow-0.7.1-Makefile.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/darksnow/files/darksnow-0.7.1-Makefile.patch b/media-sound/darksnow/files/darksnow-0.7.1-Makefile.patch
new file mode 100644
index 000000000000..0e7e6a1bfedc
--- /dev/null
+++ b/media-sound/darksnow/files/darksnow-0.7.1-Makefile.patch
@@ -0,0 +1,45 @@
+--- darksnow-0.7.1/Makefile.in
++++ darksnow-0.7.1/Makefile.in
+@@ -38,8 +38,8 @@
+
+ all: darksnow
+
+-darksnow: darksnow.o interface.o config_files.o tooltips.o man_gzip
+- $(CC) darksnow.o interface.o config_files.o tooltips.o -o darksnow @GTK_LIBS@ @GTK_CFLAGS@ -DVERSION="\"$(VERSION)\""
++darksnow: darksnow.o interface.o config_files.o tooltips.o
++ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION="\"$(VERSION)\"" darksnow.o interface.o config_files.o tooltips.o -o darksnow @GTK_LIBS@ @GTK_CFLAGS@
+
+ darksnow.o: darksnow.c
+ $(CC) $(FUNNY) @GTK_CFLAGS@ -DINTLPREFIX="\"$(INTLPREFIX)\"" -DVERSION="\"$(VERSION)\"" -c darksnow.c -o darksnow.o
+@@ -53,19 +53,15 @@
+ tooltips.o: tooltips.c
+ $(CC) $(CFLAGS) $(FUNNY) @GTK_CFLAGS@ -DINTLPREFIX="\"$(INTLPREFIX)\"" -DVERSION="\"$(VERSION)\"" -c tooltips.c -o tooltips.o
+
+-man_gzip:
+- gzip -c man/darksnow.1 > man/darksnow.1.gz
+-
+ clean:
+- rm -f *.o *~ darksnow man/darksnow.1.gz
++ rm -f *.o *~ darksnow
+ rm -rf slack darksnow.tgz
+
+ install: darksnow
+- $(INSTALL) -D --mode=0755 darksnow $(PREFIX)/bin/darksnow
+- $(INSTALL) -D --mode=0644 documentation/CHANGES $(PREFIX)/share/darksnow/changelog
+- $(INSTALL) -D --mode=0644 po/pt_BR.mo $(PREFIX)/share/locale/pt_BR/LC_MESSAGES/darksnow.mo
+- $(INSTALL) -D --mode=0644 icon/darksnow_icon.png $(PREFIX)/share/icons/hicolor/32x32/apps/darksnow.png
+- $(INSTALL) -D --mode=0644 man/darksnow.1.gz $(PREFIX)/share/man/man1/darksnow.1.gz
++ $(INSTALL) -D --mode=0755 darksnow $(DESTDIR)$(PREFIX)/bin/darksnow
++ $(INSTALL) -D --mode=0644 po/pt_BR.mo $(DESTDIR)$(PREFIX)/share/locale/pt_BR/LC_MESSAGES/darksnow.mo
++ $(INSTALL) -D --mode=0644 icon/darksnow_icon.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/32x32/apps/darksnow.png
++ $(INSTALL) -D --mode=0644 man/darksnow.1 $(DESTDIR)$(PREFIX)/share/man/man1/darksnow.1
+
+ make_pkg: darksnow
+ echo "Remember to run this option as root!"
+@@ -89,5 +85,5 @@
+ /sbin/upgradepkg darksnow-*-1rd.tgz
+
+ dist-clean: clean
+- rm aclocal.m4 config.status config.log man/darksnow.1.gz Makefile
++ rm aclocal.m4 config.status config.log Makefile
+ rm -r autom4te.cache