summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 14:20:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 21:30:51 +0100
commit0715470f3a0ab6c12ff324f93472415c65066494 (patch)
treef7331e5e7009d53fd1cafa3df758e379acd30f33 /media-sound/drumstick
parentmedia-sound/kmetronome: Drop 1.0.1 (r0) (diff)
downloadgentoo-0715470f3a0ab6c12ff324f93472415c65066494.tar.gz
gentoo-0715470f3a0ab6c12ff324f93472415c65066494.tar.bz2
gentoo-0715470f3a0ab6c12ff324f93472415c65066494.zip
media-sound/drumstick: 2.0.0 version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/drumstick')
-rw-r--r--media-sound/drumstick/Manifest1
-rw-r--r--media-sound/drumstick/drumstick-2.0.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-sound/drumstick/Manifest b/media-sound/drumstick/Manifest
index 7922a01a412a..ed207917b60d 100644
--- a/media-sound/drumstick/Manifest
+++ b/media-sound/drumstick/Manifest
@@ -1 +1,2 @@
DIST drumstick-1.1.3.tar.gz 1358468 BLAKE2B af4cc923d380a1da66c835a6302e47e31c17ff90ba9277fe6063e6029c3d4d087e85905487a4dae657cdbfb743d2ac6e6c5a30c0905c9bc736d8666105e52099 SHA512 41990c269c41dc011e14c9bf008b983cd3722ea52429ec7eabaa5689a6f69b1760fc766604378c30bb1dfab537b77f7522a13377b873308835a0e7701d24448e
+DIST drumstick-2.0.0.tar.gz 1865424 BLAKE2B ee87dd222add121c8a6faaac5b8a755e2d6f7b257db890f6bbdbf5380d9771dc5b65a73d716f0cfd343a46c4227adcd2d85e4a359fcaa445b2291dc1ac188cfe SHA512 aacb4ca5a3354da6380ba146ee7ba57e646d19fe6a5d083e00b795221453a87d1baf25965784e7c8a97b9b00a3dda643bce144f62b6a27118f081c681089381a
diff --git a/media-sound/drumstick/drumstick-2.0.0.ebuild b/media-sound/drumstick/drumstick-2.0.0.ebuild
new file mode 100644
index 000000000000..041eadd01f12
--- /dev/null
+++ b/media-sound/drumstick/drumstick-2.0.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
+HOMEPAGE="https://drumstick.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fluidsynth pulseaudio"
+
+BDEPEND="
+ dev-libs/libxslt
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ x11-misc/shared-mime-info
+ doc? (
+ app-doc/doxygen[dot]
+ app-text/docbook-xsl-stylesheets
+ )
+"
+DEPEND="
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -e "/find_package(Doxygen/s/^/# disabled by -doc/" \
+ -i CMakeLists.txt || die
+ fi
+
+ if ! use fluidsynth ; then
+ sed -e "/pkg_check_modules(FLUIDSYNTH/s/^/# disabled by -fluidsynth/" \
+ -i library/rt-backends/CMakeLists.txt || die
+ fi
+
+ if ! use pulseaudio ; then
+ sed -e "/pkg_check_modules(PULSE/s/^/# disabled by -pulseaudio/" \
+ -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DUSE_DBUS=ON
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+}