summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-11 10:42:09 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-11 10:45:24 +0200
commit171803227f3ded10b76442406583c55e3b04c0ec (patch)
tree921263b35b5afe80397dca71bad7bbf09a5fb5e7 /media-sound/exaile/exaile-4.1.0_alpha1.ebuild
parentdev-libs/mpfr: Stabilize 4.1.0 arm64, #736559 (diff)
downloadgentoo-171803227f3ded10b76442406583c55e3b04c0ec.tar.gz
gentoo-171803227f3ded10b76442406583c55e3b04c0ec.tar.bz2
gentoo-171803227f3ded10b76442406583c55e3b04c0ec.zip
media-sound/exile: bump to 4.1.0_alpha1 + added live + dropped py2
based on updated ebuild provided by Wicher Minnaard <wicher@gavagai.eu> Closes: https://bugs.gentoo.org/708966 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/exaile/exaile-4.1.0_alpha1.ebuild')
-rw-r--r--media-sound/exaile/exaile-4.1.0_alpha1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/exaile/exaile-4.1.0_alpha1.ebuild b/media-sound/exaile/exaile-4.1.0_alpha1.ebuild
new file mode 100644
index 000000000000..ea8a80d4a9e1
--- /dev/null
+++ b/media-sound/exaile/exaile-4.1.0_alpha1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+# IUSE+=cddb if have dev-python/cddb-py
+IUSE="libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gst-plugins-base-1.6:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+ media-plugins/gst-plugins-meta:1.0
+ >=x11-libs/gtk+-3.10:3[introspection]
+ libnotify? ( >=x11-libs/libnotify-0.7[introspection] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygobject-3.13.2:3[${PYTHON_MULTI_USEDEP}]
+ >=media-libs/mutagen-1.10[${PYTHON_MULTI_USEDEP}]
+ scrobbler? ( dev-python/pylast[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+
+RESTRICT="test" #315589
+
+PATCHES=(
+ "${FILESDIR}/${P}-metainfo.patch"
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}