summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen 'j0inty' Stollfuß <j0inty@fairnatics.net>2017-09-03 15:55:35 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-03 15:56:28 +1000
commitcc95a5a81c108671fe6b1d0728e541c85bbda418 (patch)
treef808c7337ea8f9540ebd4125eac8b2d589449e2f /media-sound/ezstream/ezstream-0.6.0-r1.ebuild
parentdev-libs/libzip: version bump 1.3.0 (diff)
downloadgentoo-cc95a5a81c108671fe6b1d0728e541c85bbda418.tar.gz
gentoo-cc95a5a81c108671fe6b1d0728e541c85bbda418.tar.bz2
gentoo-cc95a5a81c108671fe6b1d0728e541c85bbda418.zip
media-sound/ezstream: fix taglib detection
Gentoo-bug: 596376 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-sound/ezstream/ezstream-0.6.0-r1.ebuild')
-rw-r--r--media-sound/ezstream/ezstream-0.6.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/ezstream/ezstream-0.6.0-r1.ebuild b/media-sound/ezstream/ezstream-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..59af61c756cb
--- /dev/null
+++ b/media-sound/ezstream/ezstream-0.6.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A command line source client for Icecast media streaming servers"
+HOMEPAGE="http://www.icecast.org/ezstream/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="taglib"
+
+COMMON_DEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2.2
+ !taglib? ( media-libs/libvorbis )
+ taglib? ( media-libs/taglib )"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/icecast"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local docdir=/usr/share/doc/${PF}
+
+ econf \
+ --docdir=${docdir} \
+ --enable-examplesdir=${docdir}/examples \
+ $(use_with taglib taglib "/usr")
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ rm -f "${D%/}"/usr/share/doc/${PF}/COPYING
+}