summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-09-20 09:16:52 +0200
committerChristoph Mende <angelos@gentoo.org>2015-09-20 09:16:52 +0200
commitc6c38433767eaf66728809f6aca591073fda7c6f (patch)
tree2804c81720cdd6296e886e951943f04a17680703 /media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
parentRevert "sci-visualization/paraview: Only keep version 4.3.1" (diff)
downloadgentoo-c6c38433767eaf66728809f6aca591073fda7c6f.tar.gz
gentoo-c6c38433767eaf66728809f6aca591073fda7c6f.tar.bz2
gentoo-c6c38433767eaf66728809f6aca591073fda7c6f.zip
media-sound/gimmix: Fix format-security warning (bug #542140)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild')
-rw-r--r--media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild b/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
new file mode 100644
index 000000000000..dc9f230f6f0f
--- /dev/null
+++ b/media-sound/gimmix/gimmix-0.5.7.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="a graphical music player daemon (MPD) client using GTK+2"
+HOMEPAGE="https://launchpad.net/gimmix"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cover lyrics taglib"
+
+RDEPEND=">=media-libs/libmpd-0.17
+ gnome-base/libglade
+ x11-libs/gtk+:2
+ cover? ( net-libs/libnxml net-misc/curl )
+ lyrics? ( net-libs/libnxml net-misc/curl )
+ taglib? ( >=media-libs/taglib-1.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.7.1-curl-headers.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+ sed -i -e "/^Icon/s/\.png$//" \
+ -e "/^Categories/s/Application;//" data/gimmix.desktop
+
+ # broken build system in tarball
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable cover) \
+ $(use_enable lyrics) \
+ $(use_enable taglib tageditor)
+}