summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gmusicbrowser/gmusicbrowser-1.1.13.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gmusicbrowser/gmusicbrowser-1.1.13.ebuild')
-rw-r--r--media-sound/gmusicbrowser/gmusicbrowser-1.1.13.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/gmusicbrowser/gmusicbrowser-1.1.13.ebuild b/media-sound/gmusicbrowser/gmusicbrowser-1.1.13.ebuild
new file mode 100644
index 000000000000..79f4d4f5b5ec
--- /dev/null
+++ b/media-sound/gmusicbrowser/gmusicbrowser-1.1.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="An open-source jukebox for large collections of mp3/ogg/flac files"
+HOMEPAGE="http://gmusicbrowser.org/"
+SRC_URI="http://${PN}.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+GSTREAMER_DEPEND="
+ dev-perl/GStreamer
+ dev-perl/GStreamer-Interfaces
+ media-plugins/gst-plugins-meta:0.10"
+MPLAYER_DEPEND="media-video/mplayer"
+OTHER_DEPEND="
+ media-sound/alsa-utils
+ media-sound/flac123
+ || ( media-sound/mpg123 media-sound/mpg321 )
+ media-sound/vorbis-tools"
+
+RDEPEND="dev-lang/perl
+ dev-perl/gtk2-perl
+ virtual/perl-MIME-Base64
+ || ( net-misc/wget dev-perl/AnyEvent-HTTP )
+ || (
+ ( ${GSTREAMER_DEPEND} )
+ ( ${MPLAYER_DEPEND} )
+ ( ${OTHER_DEPEND} )
+ )"
+DEPEND="sys-devel/gettext"
+
+src_install() {
+ emake \
+ DOCS="AUTHORS NEWS README" \
+ DESTDIR="${D}" \
+ iconsdir="${D}/usr/share/icons/hicolor/32x32/apps" \
+ liconsdir="${D}/usr/share/icons/hicolor/48x48/apps" \
+ miconsdir="${D}/usr/share/pixmaps" \
+ install
+
+ dohtml layout_doc.html
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ elog "Gmusicbrowser supports gstreamer, mplayer and mpg123/ogg123..."
+ elog "for audio playback. Needed dependencies:"
+ elog "Gstreamer: ${GSTREAMER_DEPEND}"
+ elog "mplayer: ${MPLAYER_DEPEND}"
+ elog "mpg123/ogg123...: ${OTHER_DEPEND}"
+ elog
+ elog "This ebuild just ensures at least one implementation is installed!"
+ elog
+ elog "other optional dependencies:"
+ elog " dev-perl/Net-DBus (for dbus support and mpris1/2 plugins)"
+ elog " dev-perl/Gtk2-WebKit (for Web context plugin)"
+ elog " dev-perl/Gtk2-Notify (for Notify plugin)"
+ elog " dev-perl/gnome2-wnck (for Titlebar plugin)"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}