summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gnomoradio/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gnomoradio/files')
-rw-r--r--media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch22
-rw-r--r--media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc43.patch70
-rw-r--r--media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch53
-rw-r--r--media-sound/gnomoradio/files/gnomoradio-0.15.1-lm.patch12
4 files changed, 157 insertions, 0 deletions
diff --git a/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch b/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch
new file mode 100644
index 000000000000..0efc60fb868f
--- /dev/null
+++ b/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch
@@ -0,0 +1,22 @@
+diff -ur gnomoradio-0.15.1.orig/roboradio/audio/prober.h gnomoradio-0.15.1/roboradio/audio/prober.h
+--- gnomoradio-0.15.1.orig/roboradio/audio/prober.h 2004-10-17 04:40:36.000000000 +0300
++++ gnomoradio-0.15.1/roboradio/audio/prober.h 2008-06-29 14:48:13.000000000 +0300
+@@ -27,6 +27,7 @@
+ {
+ namespace Audio
+ {
++ gboolean probe (gpointer s);
+ class Prober : public Audio
+ {
+ public:
+diff -ur gnomoradio-0.15.1.orig/roboradio/state.cc gnomoradio-0.15.1/roboradio/state.cc
+--- gnomoradio-0.15.1.orig/roboradio/state.cc 2004-10-24 03:24:34.000000000 +0300
++++ gnomoradio-0.15.1/roboradio/state.cc 2008-06-29 14:48:13.000000000 +0300
+@@ -28,6 +28,7 @@
+ #include <sys/stat.h>
+ #include <dirent.h>
+ #include <iostream>
++#include <cstring>
+
+ #include <map>
+ #include <set>
diff --git a/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc43.patch b/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc43.patch
new file mode 100644
index 000000000000..b5f30edfa395
--- /dev/null
+++ b/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc43.patch
@@ -0,0 +1,70 @@
+Index: gnomoradio-0.15.1/rainbow/license.cc
+===================================================================
+--- gnomoradio-0.15.1.orig/rainbow/license.cc
++++ gnomoradio-0.15.1/rainbow/license.cc
+@@ -54,7 +54,7 @@ void Rainbow::License::get_and_do (const
+ }
+
+ if (done) {
+- signal<void,ref_ptr<License> > sig;
++ sigc::signal<void,ref_ptr<License> > sig;
+ sig.connect(slot);
+ sig(license);
+ } else {
+Index: gnomoradio-0.15.1/rainbow/rdf-resource.cc
+===================================================================
+--- gnomoradio-0.15.1.orig/rainbow/rdf-resource.cc
++++ gnomoradio-0.15.1/rainbow/rdf-resource.cc
+@@ -35,7 +35,7 @@ void Rainbow::RdfResource::get_and_do (c
+ resource = ref_ptr<RdfResource>(p->second);
+ if (resource->downloaded) { // already downloaded
+ map<Glib::ustring,xmlpp::Element*>::iterator el = resource->id_map.find(id);
+- signal<void,xmlpp::Element*,ref_ptr<RdfResource> > sig;
++ sigc::signal<void,xmlpp::Element*,ref_ptr<RdfResource> > sig;
+ sig.connect(slot);
+ sig(el != resource->id_map.end() ? el->second : 0, resource);
+ return;
+@@ -47,7 +47,7 @@ void Rainbow::RdfResource::get_and_do (c
+ Glib::ustring host, file;
+ unsigned short port;
+ if (!HttpClient::parse_url(uri, host, port, file)) {
+- signal<void,xmlpp::Element*,ref_ptr<RdfResource> > sig;
++ sigc::signal<void,xmlpp::Element*,ref_ptr<RdfResource> > sig;
+ sig.connect(slot);
+ sig(0, resource);
+ return;
+@@ -55,14 +55,14 @@ void Rainbow::RdfResource::get_and_do (c
+ }
+
+ // connect mem_fun to appropriate signal
+- map<Glib::ustring,signal<void,xmlpp::Element*, ref_ptr<RdfResource> >*>::iterator sig;
++ map<Glib::ustring,sigc::signal<void,xmlpp::Element*, ref_ptr<RdfResource> >*>::iterator sig;
+ sig = resource->signal_map.find(id);
+ if (sig != resource->signal_map.end()) {
+ // found existing signal for id
+ sig->second->connect(slot);
+ } else {
+ // need to create new signal to handle id
+- signal<void,xmlpp::Element*,ref_ptr<RdfResource> > *signal_ = new signal<void,xmlpp::Element*,ref_ptr<RdfResource> >;
++ sigc::signal<void,xmlpp::Element*,ref_ptr<RdfResource> > *signal_ = new sigc::signal<void,xmlpp::Element*,ref_ptr<RdfResource> >;
+ signal_->connect(slot);
+ resource->signal_map.insert(make_pair(id, signal_));
+ }
+@@ -190,7 +190,7 @@ void Rainbow::RdfResource::on_downloaded
+
+ error:
+ // call all signals
+- map<Glib::ustring,signal<void,xmlpp::Element*,ref_ptr<RdfResource> >*>::iterator signal;
++ map<Glib::ustring,sigc::signal<void,xmlpp::Element*,ref_ptr<RdfResource> >*>::iterator signal;
+ for (signal = signal_map.begin(); signal != signal_map.end(); ++signal) {
+ map<Glib::ustring,xmlpp::Element*>::iterator el = id_map.find(signal->first);
+ signal->second->emit(el != id_map.end() ? el->second : 0, ref_ptr<RdfResource>(this));
+@@ -204,7 +204,7 @@ void Rainbow::RdfResource::on_downloaded
+
+ void Rainbow::RdfResource::clear_signal_map ()
+ {
+- map<Glib::ustring,signal<void,xmlpp::Element*,ref_ptr<RdfResource> >*>::iterator signal;
++ map<Glib::ustring,sigc::signal<void,xmlpp::Element*,ref_ptr<RdfResource> >*>::iterator signal;
+ for (signal = signal_map.begin(); signal != signal_map.end(); ++signal)
+ delete signal->second;
+ signal_map.clear();
diff --git a/media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch b/media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch
new file mode 100644
index 000000000000..168872e57cae
--- /dev/null
+++ b/media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch
@@ -0,0 +1,53 @@
+Index: gnomoradio-0.15.1/roboradio/mp3/common.c
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/common.c
++++ gnomoradio-0.15.1/roboradio/mp3/common.c
+@@ -19,7 +19,7 @@
+ #include "id3.h"
+ #include "id3_header.h"
+
+-#include <glib/gmem.h>
++#include <glib.h>
+
+ /* max = 1728 */
+ #define MAXFRAMESIZE 1792
+Index: gnomoradio-0.15.1/roboradio/mp3/esd-audio.c
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/esd-audio.c
++++ gnomoradio-0.15.1/roboradio/mp3/esd-audio.c
+@@ -2,8 +2,7 @@
+ #include <config.h>
+ #include "esd-audio.h"
+
+-#include <glib/gmem.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <pthread.h>
+ #include <stdlib.h>
+ #include <string.h>
+Index: gnomoradio-0.15.1/roboradio/mp3/esd-audio.h
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/esd-audio.h
++++ gnomoradio-0.15.1/roboradio/mp3/esd-audio.h
+@@ -1,7 +1,7 @@
+ #ifndef ESD_AUDIO_H
+ #define ESD_AUDIO_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ #define N_(string) string
+
+Index: gnomoradio-0.15.1/roboradio/mp3/id3.h
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/id3.h
++++ gnomoradio-0.15.1/roboradio/mp3/id3.h
+@@ -28,7 +28,7 @@
+ #ifndef ID3_H
+ #define ID3_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ /*
+ * Option flags to id3_open_*().
diff --git a/media-sound/gnomoradio/files/gnomoradio-0.15.1-lm.patch b/media-sound/gnomoradio/files/gnomoradio-0.15.1-lm.patch
new file mode 100644
index 000000000000..68104e752237
--- /dev/null
+++ b/media-sound/gnomoradio/files/gnomoradio-0.15.1-lm.patch
@@ -0,0 +1,12 @@
+diff -ur gnomoradio-0.15.1.orig/roboradio/mp3/Makefile.am gnomoradio-0.15.1/roboradio/mp3/Makefile.am
+--- gnomoradio-0.15.1.orig/roboradio/mp3/Makefile.am 2004-06-15 08:45:35.000000000 +0300
++++ gnomoradio-0.15.1/roboradio/mp3/Makefile.am 2009-07-18 13:35:08.000000000 +0300
+@@ -44,7 +44,7 @@
+ mpg123.h \
+ tabinit.c \
+ $(optimized_source)
+-libroboradio_mp3_la_LIBADD = -lpthread \
++libroboradio_mp3_la_LIBADD = -lm -lpthread \
+ $(ROBORADIO_LIBS) \
+ $(AO_LIBS)
+