summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gnump3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gnump3d')
-rw-r--r--media-sound/gnump3d/Manifest1
-rw-r--r--media-sound/gnump3d/files/gnump3d.conf.d5
-rw-r--r--media-sound/gnump3d/files/gnump3d.init.d37
-rw-r--r--media-sound/gnump3d/gnump3d-3.0-r1.ebuild73
-rw-r--r--media-sound/gnump3d/gnump3d-3.0-r2.ebuild74
-rw-r--r--media-sound/gnump3d/metadata.xml5
6 files changed, 195 insertions, 0 deletions
diff --git a/media-sound/gnump3d/Manifest b/media-sound/gnump3d/Manifest
new file mode 100644
index 000000000000..2336c3f8e4a8
--- /dev/null
+++ b/media-sound/gnump3d/Manifest
@@ -0,0 +1 @@
+DIST gnump3d-3.0.tar.bz2 633215 SHA256 1ac5bd0e850b0e18ccd9d19219f5108fa84b50d8ae3825a361e8b907eab7f19c SHA512 23778604b557346e42f5cd2045cc394c7d6f7044479c74cd635dfdbbfd6835c8e3ad761d54c5cba239cc5e020b049ac11d64eb463272fc4134b7645226e2524b WHIRLPOOL ea5be9683cadb4e7b40e237b043e9c93174ae999a3d776ed96e6c039db320faa131f95aae7bcc518cd8fa5275528f9b12252c030d2847079dee2fc18c58c1827
diff --git a/media-sound/gnump3d/files/gnump3d.conf.d b/media-sound/gnump3d/files/gnump3d.conf.d
new file mode 100644
index 000000000000..9fe7523c1200
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d.conf.d
@@ -0,0 +1,5 @@
+# Set this to 0 to stop the init script from indexing your mp3s.
+# It takes the longest on the first time, but after that, it only does
+# updates.
+
+DO_INDEX=1
diff --git a/media-sound/gnump3d/files/gnump3d.init.d b/media-sound/gnump3d/files/gnump3d.init.d
new file mode 100644
index 000000000000..2a228e2de80d
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d.init.d
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_commands="index"
+
+depend() {
+ need net
+ after netmount nfsmount
+}
+
+start() {
+ ebegin "Starting gnump3d"
+
+ if [ ${DO_INDEX} -eq 1 ]; then
+ ebegin "Updating index of music files (may take a while for the first time)"
+ /usr/bin/gnump3d-index
+ eend $?
+ fi
+
+ start-stop-daemon --start --quiet --exec /usr/bin/gnump3d2 --make-pidfile \
+ --pidfile /var/run/gnump3d.pid --background -- --quiet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --pidfile /var/run/gnump3d.pid
+ eend $?
+}
+
+index() {
+ ebegin "Indexing music files"
+ /usr/bin/gnump3d-index
+ eend $?
+}
diff --git a/media-sound/gnump3d/gnump3d-3.0-r1.ebuild b/media-sound/gnump3d/gnump3d-3.0-r1.ebuild
new file mode 100644
index 000000000000..482d0f313392
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-3.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib user
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="http://www.gnu.org/software/gnump3d/"
+SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc ppc64 sparc x86"
+IUSE="sox"
+
+RDEPEND="dev-lang/perl
+ sox? ( media-sound/sox )"
+DEPEND="dev-lang/perl
+ sys-apps/sed"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewuser gnump3d '' '' '' nogroup
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ PERLDIR="`perl bin/getlibdir`"
+
+ insinto ${PERLDIR}/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto ${PERLDIR}/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto ${PERLDIR}/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ insinto /usr/share/gnump3d
+ doins -r templates/*
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ dosed "s,PLUGINDIR,${PERLDIR},g" /etc/gnump3d/gnump3d.conf
+ dosed 's,^user *= *\(.*\)$,user = gnump3d,g' /etc/gnump3d/gnump3d.conf
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ keepdir /var/cache/gnump3d/serving
+
+ fowners gnump3d:nogroup /var/log/gnump3d /var/cache/gnump3d
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ elog ""
+ elog "At the very least, you will need to change the root directory"
+ elog "where music is found. By default, gnump3d will also listen"
+ elog "to any address on port 8888"
+ elog ""
+ elog "You can optionally use sox to downmix the quality of streamed"
+ elog "music in realtime for slow connections."
+}
diff --git a/media-sound/gnump3d/gnump3d-3.0-r2.ebuild b/media-sound/gnump3d/gnump3d-3.0-r2.ebuild
new file mode 100644
index 000000000000..251e9164d822
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-3.0-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit eutils multilib user perl-module
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="http://www.gnu.org/software/gnump3d/"
+SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="sox"
+
+RDEPEND="sox? ( media-sound/sox )"
+DEPEND="sys-apps/sed"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewuser gnump3d '' '' '' nogroup
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ perl_set_version
+
+ insinto "${VENDOR_LIB}"/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ insinto /usr/share/gnump3d
+ doins -r templates/*
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ sed -e "s,PLUGINDIR,${VENDOR_LIB},g" -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+ sed -e 's,^user *= *\(.*\)$,user = gnump3d,g' -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ keepdir /var/cache/gnump3d/serving
+
+ fowners gnump3d:nogroup /var/log/gnump3d /var/cache/gnump3d
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ elog ""
+ elog "At the very least, you will need to change the root directory"
+ elog "where music is found. By default, gnump3d will also listen"
+ elog "to any address on port 8888"
+ elog ""
+ elog "You can optionally use sox to downmix the quality of streamed"
+ elog "music in realtime for slow connections."
+}
diff --git a/media-sound/gnump3d/metadata.xml b/media-sound/gnump3d/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/gnump3d/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>