summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-08 18:54:12 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-08 18:54:12 +0200
commit4b8beef54932a5061260b82a78c2e6032e8192dc (patch)
tree95a39dd179400ee541f297a511ab98dce0f04e3b /media-sound/gom
parentmedia-sound/abcmidi: Fix building under -fno-common (diff)
downloadgentoo-4b8beef54932a5061260b82a78c2e6032e8192dc.tar.gz
gentoo-4b8beef54932a5061260b82a78c2e6032e8192dc.tar.bz2
gentoo-4b8beef54932a5061260b82a78c2e6032e8192dc.zip
media-sound/gom: Fix building under -fno-common
Closes: https://bugs.gentoo.org/708028 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/gom')
-rw-r--r--media-sound/gom/files/gom-0.29.103-fno-common.patch11
-rw-r--r--media-sound/gom/gom-0.29.103-r1.ebuild34
2 files changed, 24 insertions, 21 deletions
diff --git a/media-sound/gom/files/gom-0.29.103-fno-common.patch b/media-sound/gom/files/gom-0.29.103-fno-common.patch
new file mode 100644
index 000000000000..b1ee6a1930bf
--- /dev/null
+++ b/media-sound/gom/files/gom-0.29.103-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/gom_info.h
++++ b/src/gom_info.h
+@@ -52,7 +52,7 @@
+ enum gom_info_types {GOM_INFO_ERROR=-1, GOM_INFO_QUIET, GOM_INFO_NORMAL, GOM_INFO_VERBOSE, GOM_INFO_DEBUG};
+
+ /* shown errors count */
+-int gom_info_errors;
++extern int gom_info_errors;
+
+ /*
+ * FUNCTION PROTOTYPES
diff --git a/media-sound/gom/gom-0.29.103-r1.ebuild b/media-sound/gom/gom-0.29.103-r1.ebuild
index b49d71e781ed..241883a1f654 100644
--- a/media-sound/gom/gom-0.29.103-r1.ebuild
+++ b/media-sound/gom/gom-0.29.103-r1.ebuild
@@ -1,45 +1,37 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools
DESCRIPTION="Console Mixer Program for OSS"
HOMEPAGE="http://www.fh-worms.de/~inf222"
SRC_URI="http://www.Fh-Worms.DE./~inf222/code/c/gom/released/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86"
-IUSE="examples"
-DEPEND=">=sys-libs/ncurses-5.2:0="
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
default
+ rmdir examples/standard || die
+ mv configure.{in,ac} || die
eautoreconf
}
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS ChangeLog README
-
- if use examples; then
- docinto examples
- dodoc README
- docinto examples/default
- dodoc examples/default/*
- docinto examples/two-mixers
- dodoc examples/two-mixers/*
- fi
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
}