summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gqmpeg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gqmpeg')
-rw-r--r--media-sound/gqmpeg/Manifest1
-rw-r--r--media-sound/gqmpeg/files/gqmpeg-0.91.1-libpng15.patch11
-rw-r--r--media-sound/gqmpeg/gqmpeg-0.91.1.ebuild36
-rw-r--r--media-sound/gqmpeg/metadata.xml8
4 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/gqmpeg/Manifest b/media-sound/gqmpeg/Manifest
new file mode 100644
index 000000000000..1eb1d0943f28
--- /dev/null
+++ b/media-sound/gqmpeg/Manifest
@@ -0,0 +1 @@
+DIST gqmpeg-0.91.1.tar.gz 1078478 SHA256 78502bf9b9119c9d4495a640e7467c67aa992b30d8b5b2a51c1db86ada045df5
diff --git a/media-sound/gqmpeg/files/gqmpeg-0.91.1-libpng15.patch b/media-sound/gqmpeg/files/gqmpeg-0.91.1-libpng15.patch
new file mode 100644
index 000000000000..f89565b30e10
--- /dev/null
+++ b/media-sound/gqmpeg/files/gqmpeg-0.91.1-libpng15.patch
@@ -0,0 +1,11 @@
+--- src/ui_pixbuf_save.c
++++ src/ui_pixbuf_save.c
+@@ -86,7 +86,7 @@ gboolean pixbuf_to_file_as_png (GdkPixbu
+ return FALSE;
+ }
+
+- if (setjmp (png_ptr->jmpbuf))
++ if (setjmp (png_jmpbuf(png_ptr)))
+ {
+ png_destroy_write_struct (&png_ptr, &info_ptr);
+ fclose (handle);
diff --git a/media-sound/gqmpeg/gqmpeg-0.91.1.ebuild b/media-sound/gqmpeg/gqmpeg-0.91.1.ebuild
new file mode 100644
index 000000000000..d8dd5d11ebd6
--- /dev/null
+++ b/media-sound/gqmpeg/gqmpeg-0.91.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="front end to various audio players, including mpg123"
+HOMEPAGE="http://gqmpeg.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2
+ media-sound/vorbis-tools
+ media-sound/mpg123
+ >=media-libs/libpng-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog FAQ NEWS README SKIN-SPECS* TODO
+}
diff --git a/media-sound/gqmpeg/metadata.xml b/media-sound/gqmpeg/metadata.xml
new file mode 100644
index 000000000000..c1a71961758e
--- /dev/null
+++ b/media-sound/gqmpeg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">gqmpeg</remote-id>
+ </upstream>
+</pkgmetadata>