summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-12-30 01:49:26 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2020-12-30 07:28:01 +0100
commit955f39d25ea93a822279a1c682a3fa3fe01acb29 (patch)
tree222c06fd90c774607d4abc38662b1afcf291a585 /media-sound/guitarix/guitarix-0.42.1.ebuild
parentmail-filter/imapfilter: upgrade to 2.7.5 (diff)
downloadgentoo-955f39d25ea93a822279a1c682a3fa3fe01acb29.tar.gz
gentoo-955f39d25ea93a822279a1c682a3fa3fe01acb29.tar.bz2
gentoo-955f39d25ea93a822279a1c682a3fa3fe01acb29.zip
media-sound/guitarix: Version bump to 0.42.1
* EAPI 7 bump * reorganize dependencies * support python3.9 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/guitarix/guitarix-0.42.1.ebuild')
-rw-r--r--media-sound/guitarix/guitarix-0.42.1.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/media-sound/guitarix/guitarix-0.42.1.ebuild b/media-sound/guitarix/guitarix-0.42.1.ebuild
new file mode 100644
index 000000000000..2c8d5e6f5a0f
--- /dev/null
+++ b/media-sound/guitarix/guitarix-0.42.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils xdg
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="https://guitarix.org/"
+SRC_URI="mirror://sourceforge/guitarix/guitarix/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bluetooth debug lv2 nls nsm +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ >=media-libs/libsndfile-1.0.17
+ >=media-libs/zita-convolver-3:=
+ media-libs/zita-resampler
+ >=net-misc/curl-7.26.0
+ >=sci-libs/fftw-3.3.8:3.0=
+ x11-libs/gtk+:3
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ nsm? ( media-libs/liblo )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# roboto fonts are required for correct ui rendering
+RDEPEND="
+ ${DEPEND}
+ standalone? (
+ media-fonts/roboto
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ standalone? (
+ dev-lang/sassc
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ )
+"
+
+DOCS=( changelog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.41.0-nostrip.patch
+)
+
+src_configure() {
+ local myconf=(
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex nsm "" "--no-nsm")
+ $(usex standalone "" "--no-standalone")
+ $(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
+}