summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/herrie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/herrie')
-rw-r--r--media-sound/herrie/Manifest1
-rw-r--r--media-sound/herrie/files/herrie-2.2-libxspf.patch122
-rw-r--r--media-sound/herrie/files/herrie-chost_issue.patch29
-rw-r--r--media-sound/herrie/herrie-2.2.ebuild71
-rw-r--r--media-sound/herrie/metadata.xml24
5 files changed, 247 insertions, 0 deletions
diff --git a/media-sound/herrie/Manifest b/media-sound/herrie/Manifest
new file mode 100644
index 000000000000..18e1eacc29d0
--- /dev/null
+++ b/media-sound/herrie/Manifest
@@ -0,0 +1 @@
+DIST herrie-2.2.tar.bz2 71596 SHA256 142341072920f86b6eb570b8f13bf5fd87c06cf801543dc7d1a819e39eb9fb2b
diff --git a/media-sound/herrie/files/herrie-2.2-libxspf.patch b/media-sound/herrie/files/herrie-2.2-libxspf.patch
new file mode 100644
index 000000000000..00dc3057b205
--- /dev/null
+++ b/media-sound/herrie/files/herrie-2.2-libxspf.patch
@@ -0,0 +1,122 @@
+--- configure
++++ configure
+@@ -301,7 +301,7 @@ fi
+ if [ "$CFG_XSPF" != "" ]
+ then
+ CFLAGS="$CFLAGS -DBUILD_XSPF"
+- LDFLAGS="$LDFLAGS -lspiff"
++ test_pkgconfig "libxspf" "xspf" "_vfs_xspf"
+ SRCS="$SRCS util vfs_xspf"
+ PLAYQ_DUMPFILE="autosave.xspf"
+ else
+--- src/conftest.c
++++ src/conftest.c
+@@ -56,16 +56,10 @@
+ #include <vorbis/codec.h>
+ #include <vorbis/vorbisfile.h>
+ #endif /* BUILD_VORBIS */
+-#ifdef BUILD_XSPF
+-#include <spiff/spiff_c.h>
+-#endif /* BUILD_XSPF */
+
+ int
+ main(int argc, char *argv[])
+ {
+-#ifdef BUILD_XSPF
+- spiff_write(NULL, NULL, NULL);
+-#endif /* BUILD_XSPF */
+
+ return (0);
+ }
+--- src/vfs_xspf.c
++++ src/vfs_xspf.c
+@@ -30,7 +30,7 @@
+
+ #include "stdinc.h"
+
+-#include <spiff/spiff_c.h>
++#include <xspf_c.h>
+
+ #include "util.h"
+ #include "vfs.h"
+@@ -50,22 +50,22 @@ vfs_xspf_match(struct vfsent *ve, int isdir)
+ int
+ vfs_xspf_populate(struct vfsent *ve)
+ {
+- struct spiff_list *slist;
+- struct spiff_track *strack;
+- struct spiff_mvalue *sloc;
++ struct xspf_list *slist;
++ struct xspf_track *strack;
++ struct xspf_mvalue *sloc;
+ char *dirname, *baseuri, *filename;
+ struct vfsref *vr;
+
+ baseuri = url_escape(ve->filename);
+- slist = spiff_parse(ve->filename, baseuri);
++ slist = xspf_parse(ve->filename, baseuri);
+ g_free(baseuri);
+ if (slist == NULL)
+ return (-1);
+
+ dirname = g_path_get_dirname(ve->filename);
+
+- SPIFF_LIST_FOREACH_TRACK(slist, strack) {
+- SPIFF_TRACK_FOREACH_LOCATION(strack, sloc) {
++ XSPF_LIST_FOREACH_TRACK(slist, strack) {
++ XSPF_TRACK_FOREACH_LOCATION(strack, sloc) {
+ /* Skip file:// part */
+ filename = url_unescape(sloc->value);
+
+@@ -77,40 +77,40 @@ vfs_xspf_populate(struct vfsent *ve)
+ }
+
+ g_free(dirname);
+- spiff_free(slist);
++ xspf_free(slist);
+ return (0);
+ }
+
+ int
+ vfs_xspf_write(const struct vfslist *vl, const char *filename)
+ {
+- struct spiff_list *list;
+- struct spiff_track *track;
+- struct spiff_mvalue *location;
++ struct xspf_list *list;
++ struct xspf_track *track;
++ struct xspf_mvalue *location;
+ char *fn, *baseuri;
+ struct vfsref *vr;
+ int ret;
+
+- list = spiff_new();
++ list = xspf_new();
+
+ VFS_LIST_FOREACH_REVERSE(vl, vr) {
+ /* Add a new track to the beginning of the list */
+- track = spiff_new_track_before(&list->tracks);
++ track = xspf_new_track_before(&list->tracks);
+
+ /* Make sure we don't write non-UTF-8 titles to disk */
+ if (g_utf8_validate(vfs_name(vr), -1, NULL))
+- spiff_setvalue(&track->title, vfs_name(vr));
++ xspf_setvalue(&track->title, vfs_name(vr));
+
+- location = spiff_new_mvalue_before(&track->locations);
++ location = xspf_new_mvalue_before(&track->locations);
+ fn = url_escape(vfs_filename(vr));
+- spiff_setvalue(&location->value, fn);
++ xspf_setvalue(&location->value, fn);
+ g_free(fn);
+ }
+
+ baseuri = url_escape(filename);
+- ret = spiff_write(list, filename, baseuri);
++ ret = xspf_write(list, filename, baseuri);
+ g_free(baseuri);
+- spiff_free(list);
++ xspf_free(list);
+
+ return (ret);
+ }
diff --git a/media-sound/herrie/files/herrie-chost_issue.patch b/media-sound/herrie/files/herrie-chost_issue.patch
new file mode 100644
index 000000000000..1949972baa6a
--- /dev/null
+++ b/media-sound/herrie/files/herrie-chost_issue.patch
@@ -0,0 +1,29 @@
+This patch sets the OS variable according to the CHOST given by the environment,
+thus enabling cross-compilation.
+
+Index: herrie-1.8/configure
+===================================================================
+--- herrie-1.8.orig/configure
++++ herrie-1.8/configure
+@@ -50,6 +50,21 @@ CFG_VORBIS=yes
+ CFG_XSPF=yes
+ DOIT=@
+
++case "$CHOST" in
++ *-darwin*)
++ OS=Darwin
++ ;;
++ *-linux*)
++ OS=Linux
++ ;;
++ *-freebsd*)
++ OS=FreeBSD
++ ;;
++ *-solaris*)
++ OS=SunOS
++ ;;
++esac
++
+ # Operating system defaults
+ [ "$OS" != "" ] || OS=`uname`
+ case $OS in
diff --git a/media-sound/herrie/herrie-2.2.ebuild b/media-sound/herrie/herrie-2.2.ebuild
new file mode 100644
index 000000000000..e258c54365f0
--- /dev/null
+++ b/media-sound/herrie/herrie-2.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Herrie is a command line music player"
+HOMEPAGE="http://herrie.info/"
+SRC_URI="http://herrie.info/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ao alsa pulseaudio oss http modplug mp3 sndfile vorbis xspf unicode nls"
+
+APP_LINGUAS="ca da de es fi ga nl pl pt_BR ru sv tr vi zh_CN"
+for X in ${APP_LINGUAS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="sys-libs/ncurses[unicode?]
+ >=dev-libs/glib-2:2
+ ao? ( media-libs/libao )
+ alsa? ( media-libs/alsa-lib )
+ http? ( net-misc/curl )
+ modplug? ( media-libs/libmodplug )
+ mp3? ( media-libs/libmad
+ media-libs/libid3tag )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )
+ xspf? ( >=media-libs/libxspf-1.2 )
+ !ao? ( !alsa? ( !pulseaudio? ( !oss? ( media-libs/alsa-lib ) ) ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-chost_issue.patch \
+ "${FILESDIR}"/${P}-libxspf.patch
+}
+
+src_configure() {
+ if ! use ao && ! use alsa && ! use pulseaudio && ! use oss; then
+ ewarn "No audio output selected (ao, alsa, pulseaudio, oss), defaulting to alsa."
+ fi
+
+ local EXTRA_CONF="verbose no_strip"
+ use ao && EXTRA_CONF="${EXTRA_CONF} ao"
+ use alsa && EXTRA_CONF="${EXTRA_CONF} alsa"
+ use http || EXTRA_CONF="${EXTRA_CONF} no_http no_scrobbler"
+ use mp3 || EXTRA_CONF="${EXTRA_CONF} no_mp3"
+ use modplug || EXTRA_CONF="${EXTRA_CONF} no_modplug"
+ use nls || EXTRA_CONF="${EXTRA_CONF} no_nls"
+ use oss && EXTRA_CONF="${EXTRA_CONF} oss"
+ use pulseaudio && EXTRA_CONF="${EXTRA_CONF} pulse"
+ use sndfile || EXTRA_CONF="${EXTRA_CONF} no_sndfile"
+ use unicode || EXTRA_CONF="${EXTRA_CONF} ncurses"
+ use vorbis || EXTRA_CONF="${EXTRA_CONF} no_vorbis"
+ use xspf || EXTRA_CONF="${EXTRA_CONF} no_xspf"
+
+ einfo "./configure ${EXTRA_CONF}"
+ CC="$(tc-getCC)" PREFIX=/usr MANDIR=/usr/share/man \
+ ./configure ${EXTRA_CONF} || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}
diff --git a/media-sound/herrie/metadata.xml b/media-sound/herrie/metadata.xml
new file mode 100644
index 000000000000..45200fa35db8
--- /dev/null
+++ b/media-sound/herrie/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ Herrie is a minimalistic music player that uses the command
+ line. It is written to support a variety of operating systems,
+ audio subsystems and file formats, including playlists.
+
+ Herrie has a split-screen user interface, with a playlist at
+ the top of the screen and a file browser at the bottom. When
+ tracks are added to the playlist, Herrie consumes them from the
+ top one by one. It is thus an application that allows you to
+ batch music for playback.
+
+ Herrie also has some more exotic features, including support
+ for AudioScrobbler and the ability to chroot() itself
+ into a directory.
+ </longdescription>
+ <use>
+ <flag name="http">Enable http streaming</flag>
+ <flag name="xspf">Enable support for reading and saving XSPF playlists</flag>
+ </use>
+</pkgmetadata>