summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-20 19:48:54 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-20 19:48:54 +0100
commitf00f7f3dc5dee4e7a6210f03db21f15ea8479938 (patch)
tree2e073c3832212a0f2bf4d01d9ee16abe009f8b8b /media-sound/id3
parentmedia-sound/xineadump: update EAPI 6 -> 8 (diff)
downloadgentoo-f00f7f3dc5dee4e7a6210f03db21f15ea8479938.tar.gz
gentoo-f00f7f3dc5dee4e7a6210f03db21f15ea8479938.tar.bz2
gentoo-f00f7f3dc5dee4e7a6210f03db21f15ea8479938.zip
media-sound/id3: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/id3')
-rw-r--r--media-sound/id3/files/id3-0.15-makefile.patch32
-rw-r--r--media-sound/id3/id3-0.15-r2.ebuild (renamed from media-sound/id3/id3-0.15-r1.ebuild)15
2 files changed, 37 insertions, 10 deletions
diff --git a/media-sound/id3/files/id3-0.15-makefile.patch b/media-sound/id3/files/id3-0.15-makefile.patch
new file mode 100644
index 000000000000..265fa0970269
--- /dev/null
+++ b/media-sound/id3/files/id3-0.15-makefile.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -3,9 +3,6 @@
+
+ SHELL = /bin/sh
+
+-CC = gcc
+-CFLAGS = -g -O2
+-LDFLAGS =
+ LIBS =
+ DEFS =
+ INSTALL = /usr/bin/install -c
+@@ -20,11 +17,6 @@
+ SRCS = id3.c
+ OBJS = $(SRCS:.c=.o)
+
+-.SUFFIXES: .c .o
+-
+-.c.o:
+- $(CC) $(DEFS) $(CFLAGS) -c $<
+-
+ all: $(PRODUCT)
+
+ $(PRODUCT): $(OBJS)
+@@ -35,6 +27,6 @@
+
+ install: $(PRODUCT)
+ $(INSTALL) -d -m 755 $(bindir)
+- $(INSTALL) -s -m 755 -o 0 $(PRODUCT) $(bindir)
++ $(INSTALL) -m 755 -o 0 $(PRODUCT) $(bindir)
+ $(INSTALL) -d -m 755 $(mandir)
+ $(INSTALL) -m 644 -o 0 $(PRODUCT).1 $(mandir)
diff --git a/media-sound/id3/id3-0.15-r1.ebuild b/media-sound/id3/id3-0.15-r2.ebuild
index 3cdb64eae22d..27233f54fba6 100644
--- a/media-sound/id3/id3-0.15-r1.ebuild
+++ b/media-sound/id3/id3-0.15-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,14 +12,9 @@ SRC_URI="http://lly.org/~rcw/id3/${PN}_${PV}.orig.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~riscv sparc x86"
-IUSE=""
-src_prepare() {
- default
- sed -i -e "s:-s::" Makefile || die "sed failed"
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export CC
}