summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/jaaa/files/jaaa-0.6.0-makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/jaaa/files/jaaa-0.6.0-makefile.patch')
-rw-r--r--media-sound/jaaa/files/jaaa-0.6.0-makefile.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-sound/jaaa/files/jaaa-0.6.0-makefile.patch b/media-sound/jaaa/files/jaaa-0.6.0-makefile.patch
new file mode 100644
index 000000000000..cfbe5be6b175
--- /dev/null
+++ b/media-sound/jaaa/files/jaaa-0.6.0-makefile.patch
@@ -0,0 +1,23 @@
+Index: jaaa-0.6.0/Makefile
+===================================================================
+--- jaaa-0.6.0.orig/Makefile
++++ jaaa-0.6.0/Makefile
+@@ -24,8 +24,7 @@ SUFFIX := $(shell uname -m | sed -e 's/^
+ LIBDIR = lib$(SUFFIX)
+ VERSION = 0.6.0
+ DISTDIR = jaaa-$(VERSION)
+-CPPFLAGS += -O2 -Wall -MMD -MP -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(PREFIX)\" -I/usr/include/freetype2
+-CPPFLAGS += -march=native
++CPPFLAGS += -Wall -MMD -MP -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(PREFIX)\" -I/usr/include/freetype2
+
+ LDFLAGS += -L$(PREFIX)/$(LIBDIR) -L/usr/X11R6/$(LIBDIR)
+ LDLIBS += -lclalsadrv -lclthreads -lclxclient -lpthread -lfftw3f -ljack -lasound -lpthread -lXft -lX11 -lrt
+@@ -33,7 +32,7 @@ LDLIBS += -lclalsadrv -lclthreads -lclxc
+
+ JAAA_O = jaaa.o styles.o spectwin.o audio.o rngen.o
+ jaaa: $(JAAA_O)
+- g++ $(LDFLAGS) -o $@ $(JAAA_O) $(LDLIBS)
++ $(CXX) $(LDFLAGS) -o $@ $(JAAA_O) $(LDLIBS)
+
+ $(JAAA_O):
+ -include $(JAAA_O:%.o=%.d)