summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/kid3/kid3-3.1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/kid3/kid3-3.1.2.ebuild')
-rw-r--r--media-sound/kid3/kid3-3.1.2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/kid3/kid3-3.1.2.ebuild b/media-sound/kid3/kid3-3.1.2.ebuild
new file mode 100644
index 000000000000..723169de5a30
--- /dev/null
+++ b/media-sound/kid3/kid3-3.1.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="cs de es et fi fr it nl pl ru sr sr@ijekavian sr@ijekavianlatin
+sr@Latn tr zh_CN zh_TW"
+KDE_REQUIRED="optional"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A simple tag editor for KDE"
+HOMEPAGE="http://kid3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="acoustid flac kde mp3 mp4 +phonon +taglib vorbis"
+
+REQUIRED_USE="flac? ( vorbis )"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ sys-libs/readline:0
+ acoustid? (
+ media-libs/chromaprint
+ virtual/ffmpeg
+ )
+ flac? (
+ media-libs/flac[cxx]
+ media-libs/libvorbis
+ )
+ mp3? ( media-libs/id3lib )
+ mp4? ( media-libs/libmp4v2:0 )
+ phonon? ( || (
+ media-libs/phonon[qt4]
+ dev-qt/qtphonon:4
+ ) )
+ taglib? ( >=media-libs/taglib-1.9.1 )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with acoustid CHROMAPRINT)
+ $(cmake-utils_use_with flac)
+ $(cmake-utils_use_with mp3 ID3LIB)
+ $(cmake-utils_use_with mp4 MP4V2)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with taglib)
+ $(cmake-utils_use_with vorbis)
+ "-DWITH_QT5=OFF"
+ )
+
+ if use kde; then
+ mycmakeargs+=("-DWITH_APPS=KDE;CLI")
+ else
+ mycmakeargs+=("-DWITH_APPS=Qt;CLI")
+ fi
+
+ kde4-base_src_configure
+}