summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-17 15:16:55 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-17 15:50:01 +0200
commit00dccbb934cfa50d3797ed18b19ad4f30a365e5b (patch)
tree4556d2d35fe37bf6e4c3cf154051366ac35f1347 /media-sound/lilycomp
parentapp-misc/recoll: Drop old (diff)
downloadgentoo-00dccbb934cfa50d3797ed18b19ad4f30a365e5b.tar.gz
gentoo-00dccbb934cfa50d3797ed18b19ad4f30a365e5b.tar.bz2
gentoo-00dccbb934cfa50d3797ed18b19ad4f30a365e5b.zip
media-sound/lilycomp: Bump eapi, use new python eclasses, fix docs installation.
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound/lilycomp')
-rw-r--r--media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild b/media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..57af1c754917
--- /dev/null
+++ b/media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1
+
+MY_P="${P/-/.}"
+
+DESCRIPTION="graphical note entry program for use with LilyPond"
+HOMEPAGE="http://lilycomp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+HTML_DOCS=( "${S}/lilycomp.html" )
+
+src_prepare() {
+ default
+ python_fix_shebang lilycomp.py
+}
+
+src_install() {
+ default
+ newbin lilycomp.py lilycomp
+}