summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-05 10:31:24 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-05 10:31:40 +0200
commit567c5bc07e771ba1d236510cd9ada578700b61c3 (patch)
tree0fd9dd43ff31256bc62a4e1de1abd19d508d5f11 /media-sound/lilypond
parentmedia-gfx/fbida: Depend on x11-libs/motif[xft] (diff)
downloadgentoo-567c5bc07e771ba1d236510cd9ada578700b61c3.tar.gz
gentoo-567c5bc07e771ba1d236510cd9ada578700b61c3.tar.bz2
gentoo-567c5bc07e771ba1d236510cd9ada578700b61c3.zip
media-sound/lilypond: fixed hardcoded ar command
Closes: https://bugs.gentoo.org/734176 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/lilypond-2.21.1-r1.ebuild7
-rw-r--r--media-sound/lilypond/lilypond-2.21.4-r1.ebuild7
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild7
3 files changed, 15 insertions, 6 deletions
diff --git a/media-sound/lilypond/lilypond-2.21.1-r1.ebuild b/media-sound/lilypond/lilypond-2.21.1-r1.ebuild
index 521872ddafbd..ac757af28f21 100644
--- a/media-sound/lilypond/lilypond-2.21.1-r1.ebuild
+++ b/media-sound/lilypond/lilypond-2.21.1-r1.ebuild
@@ -79,9 +79,11 @@ src_prepare() {
}
src_configure() {
+ # fix hardcoded `ar`
+ sed -i "s/AR=ar/AR=$(tc-getAR)/g" flower/GNUmakefile || die "Failed to fix ar command"
+
# documentation generation currently not supported since it requires a newer
# version of texi2html than is currently in the tree
-
local myeconfargs=(
--with-texgyre-dir=/usr/share/fonts/tex-gyre
--disable-documentation
@@ -90,9 +92,10 @@ src_configure() {
$(use_enable debug debugging)
$(use_enable profile profiling)
)
+
export VARTEXFONTS="${T}/fonts" # https://bugs.gentoo.org/692010
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}" AR="$(tc-getAR)"
}
src_compile() {
diff --git a/media-sound/lilypond/lilypond-2.21.4-r1.ebuild b/media-sound/lilypond/lilypond-2.21.4-r1.ebuild
index 0196e4c7d4d9..5fb8dcb93deb 100644
--- a/media-sound/lilypond/lilypond-2.21.4-r1.ebuild
+++ b/media-sound/lilypond/lilypond-2.21.4-r1.ebuild
@@ -79,9 +79,11 @@ src_prepare() {
}
src_configure() {
+ # fix hardcoded `ar`
+ sed -i "s/AR=ar/AR=$(tc-getAR)/g" flower/GNUmakefile || die "Failed to fix ar command"
+
# documentation generation currently not supported since it requires a newer
# version of texi2html than is currently in the tree
-
local myeconfargs=(
--with-texgyre-dir=/usr/share/fonts/tex-gyre
--disable-documentation
@@ -90,9 +92,10 @@ src_configure() {
$(use_enable debug debugging)
$(use_enable profile profiling)
)
+
export VARTEXFONTS="${T}/fonts" # https://bugs.gentoo.org/692010
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}" AR="$(tc-getAR)"
}
src_compile() {
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index fc14ef8ed34b..ffa9b40c076b 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -78,9 +78,11 @@ src_prepare() {
}
src_configure() {
+ # fix hardcoded `ar`
+ sed -i "s/AR=ar/AR=$(tc-getAR)/g" flower/GNUmakefile || die "Failed to fix ar command"
+
# documentation generation currently not supported since it requires a newer
# version of texi2html than is currently in the tree
-
local myeconfargs=(
--with-texgyre-dir=/usr/share/fonts/tex-gyre
--disable-documentation
@@ -89,9 +91,10 @@ src_configure() {
$(use_enable debug debugging)
$(use_enable profile profiling)
)
+
export VARTEXFONTS="${T}/fonts" # https://bugs.gentoo.org/692010
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}" AR="$(tc-getAR)"
}
src_compile() {