summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lingot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lingot')
-rw-r--r--media-sound/lingot/Manifest2
-rw-r--r--media-sound/lingot/files/lingot-0.7.6-clean-install.patch24
-rw-r--r--media-sound/lingot/files/lingot-0.9.0-jack.patch32
-rw-r--r--media-sound/lingot/files/lingot-0.9.1-clean-install.patch23
-rw-r--r--media-sound/lingot/lingot-0.9.0.ebuild44
-rw-r--r--media-sound/lingot/lingot-0.9.1.ebuild42
-rw-r--r--media-sound/lingot/metadata.xml5
7 files changed, 172 insertions, 0 deletions
diff --git a/media-sound/lingot/Manifest b/media-sound/lingot/Manifest
new file mode 100644
index 000000000000..7af399ba5261
--- /dev/null
+++ b/media-sound/lingot/Manifest
@@ -0,0 +1,2 @@
+DIST lingot-0.9.0.tar.gz 420806 RMD160 29cdb4c6afffe389a89cac9647918af76b09915c SHA1 b183cffc1bfda66257595c416e4cd07dbda38ed7 SHA256 ab1fc0cc45e03da6d7c92711bbd8e1691816c2e209108c80f99a54746912e11f
+DIST lingot-0.9.1.tar.gz 440043 RMD160 bd0292c541040c97fda50525e8493ad7cecd122c SHA1 e27e91ee3fa9059b08ace37f5029e9de0a5990e1 SHA256 ec91223ab3df7c9160e6f1ededd8125e64764360caa0de39f54ef0668d56f979
diff --git a/media-sound/lingot/files/lingot-0.7.6-clean-install.patch b/media-sound/lingot/files/lingot-0.7.6-clean-install.patch
new file mode 100644
index 000000000000..688aea188efd
--- /dev/null
+++ b/media-sound/lingot/files/lingot-0.7.6-clean-install.patch
@@ -0,0 +1,24 @@
+diff -ur lingot-0.7.6.orig/Makefile.am lingot-0.7.6/Makefile.am
+--- lingot-0.7.6.orig/Makefile.am 2007-12-23 21:45:19.000000000 +0200
++++ lingot-0.7.6/Makefile.am 2008-05-08 13:00:18.000000000 +0300
+@@ -8,19 +8,12 @@
+ lingotdocdir = ${docdir}
+ lingotdoc_DATA = \
+ README\
+- COPYING\
+ AUTHORS\
+ ChangeLog\
+- INSTALL\
+ NEWS\
+ TODO\
+ THANKS\
+- MAINTAINERS\
+- src/lingot-background.xpm\
+- src/lingot-logo.xpm\
+- intltool-extract.in\
+- intltool-merge.in\
+- intltool-update.in
++ MAINTAINERS
+
+ EXTRA_DIST = $(lingotdoc_DATA)
+
diff --git a/media-sound/lingot/files/lingot-0.9.0-jack.patch b/media-sound/lingot/files/lingot-0.9.0-jack.patch
new file mode 100644
index 000000000000..c7885a4098e0
--- /dev/null
+++ b/media-sound/lingot/files/lingot-0.9.0-jack.patch
@@ -0,0 +1,32 @@
+--- a/src/lingot-audio-jack.c
++++ b/src/lingot-audio-jack.c
+@@ -177,7 +177,7 @@
+ const char **ports = NULL;
+ const char* exception;
+
+- unsigned long int flags = JackPortIsActive | JackPortIsOutput;
++ unsigned long int flags = JackPortIsOutput;
+
+ try {
+ if (client != NULL) {
+@@ -265,8 +265,9 @@
+ throw(_("Cannot activate client"));
+ }
+
+- ports = jack_get_ports(audio->jack_client, NULL, NULL, JackPortIsActive
+- | JackPortIsOutput);
++ ports
++ = jack_get_ports(audio->jack_client, NULL, NULL,
++ JackPortIsOutput);
+ if (ports == NULL) {
+ throw(_("No active capture ports"));
+ }
+@@ -321,7 +322,7 @@
+ # ifdef JACK
+ //jack_cycle_wait(audio->jack_client);
+ const char** ports = jack_get_ports(audio->jack_client, NULL, NULL,
+- JackPortIsActive | JackPortIsOutput);
++ JackPortIsOutput);
+
+ if (ports != NULL) {
+ int i, j = 0;
diff --git a/media-sound/lingot/files/lingot-0.9.1-clean-install.patch b/media-sound/lingot/files/lingot-0.9.1-clean-install.patch
new file mode 100644
index 000000000000..826a9fd29ce2
--- /dev/null
+++ b/media-sound/lingot/files/lingot-0.9.1-clean-install.patch
@@ -0,0 +1,23 @@
+--- lingot-0.9.1.orig/Makefile.am
++++ lingot-0.9.1/Makefile.am
+@@ -8,19 +8,11 @@
+ lingotdocdir = ${docdir}
+ lingotdoc_DATA = \
+ README\
+- COPYING\
+ AUTHORS\
+ ChangeLog\
+- INSTALL\
+ NEWS\
+- TODO\
+ THANKS\
+- MAINTAINERS\
+- src/lingot-background.xpm\
+- src/lingot-logo.xpm\
+- intltool-extract.in\
+- intltool-merge.in\
+- intltool-update.in
++ MAINTAINERS
+
+ EXTRA_DIST = $(lingotdoc_DATA)
+
diff --git a/media-sound/lingot/lingot-0.9.0.ebuild b/media-sound/lingot/lingot-0.9.0.ebuild
new file mode 100644
index 000000000000..6b86955bb473
--- /dev/null
+++ b/media-sound/lingot/lingot-0.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="LINGOT Is Not a Guitar-Only Tuner"
+HOMEPAGE="http://www.nongnu.org/lingot"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.102 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.6-clean-install.patch \
+ "${FILESDIR}"/${P}-jack.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable jack)
+}
+
+src_install() {
+ emake DESTDIR="${D}" lingotdocdir="/usr/share/doc/${PF}" install
+}
diff --git a/media-sound/lingot/lingot-0.9.1.ebuild b/media-sound/lingot/lingot-0.9.1.ebuild
new file mode 100644
index 000000000000..e18391f84985
--- /dev/null
+++ b/media-sound/lingot/lingot-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="LINGOT Is Not a Guitar-Only Tuner"
+HOMEPAGE="http://www.nongnu.org/lingot"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.102 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-clean-install.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable jack)
+}
+
+src_install() {
+ emake DESTDIR="${D}" lingotdocdir="/usr/share/doc/${PF}" install
+}
diff --git a/media-sound/lingot/metadata.xml b/media-sound/lingot/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-sound/lingot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>