summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-09-07 12:02:20 +0200
committerJohannes Huber <johu@gentoo.org>2019-09-07 12:03:44 +0200
commit203d18085e465cbebbcc0740941b30f2e55f5db8 (patch)
treef7d5d32fe750eb90dd0926e3142d3c31933dfdae /media-sound/lollypop/lollypop-1.1.4.16.ebuild
parentnet-misc/ntpsec: restore back the stable keyword wrt bug #692494 (diff)
downloadgentoo-203d18085e465cbebbcc0740941b30f2e55f5db8.tar.gz
gentoo-203d18085e465cbebbcc0740941b30f2e55f5db8.tar.bz2
gentoo-203d18085e465cbebbcc0740941b30f2e55f5db8.zip
media-sound/lollypop: Version bump 1.1.4.16
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop/lollypop-1.1.4.16.ebuild')
-rw-r--r--media-sound/lollypop/lollypop-1.1.4.16.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/lollypop/lollypop-1.1.4.16.ebuild b/media-sound/lollypop/lollypop-1.1.4.16.ebuild
new file mode 100644
index 000000000000..c83209d2db1d
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.1.4.16.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="6b4e4e7a2c17f0770c1e2b3354ae5a3a"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}