summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mangler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mangler')
-rw-r--r--media-sound/mangler/Manifest1
-rw-r--r--media-sound/mangler/mangler-1.2.5-r1.ebuild57
-rw-r--r--media-sound/mangler/metadata.xml13
3 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/mangler/Manifest b/media-sound/mangler/Manifest
new file mode 100644
index 000000000000..f480eeeca01c
--- /dev/null
+++ b/media-sound/mangler/Manifest
@@ -0,0 +1 @@
+DIST mangler-1.2.5.tar.bz2 5390985 SHA256 baae921ac7d0708bf1f435977fa834e41e66007532a39009154835bc4677a55f SHA512 e72eb2f408ba925d10563c6821e08406007bd0b7586f9ee054a1de421a6195351140a2df9656a45389f5f568ebf44f53fb719fbf6fb113695f230dd4bad21e38 WHIRLPOOL 29364187c730dedefeb9017b01e0a426572ce47b6e98efafd2735a96aba1ea722c23b50a92bc9f675960361f703899bbac295c6359a63f54cb208e1bae8bdc52
diff --git a/media-sound/mangler/mangler-1.2.5-r1.ebuild b/media-sound/mangler/mangler-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..d8d817c42a09
--- /dev/null
+++ b/media-sound/mangler/mangler-1.2.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open source VOIP client capable of connecting to Ventrilo 3.x servers"
+HOMEPAGE="http://www.mangler.org/"
+SRC_URI="http://www.mangler.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+alsa opus espeak g15 +gsm oss pulseaudio static-libs +speex +xosd"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/glib-2.20.1:2
+ >=x11-libs/gtk+-2.16:2
+ x11-libs/libX11
+ x11-libs/libXi
+ alsa? ( media-libs/alsa-lib )
+ opus? ( media-libs/opus )
+ espeak? ( app-accessibility/espeak )
+ g15? ( app-misc/g15daemon )
+ gsm? ( media-sound/gsm )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.14 )
+ speex? ( >=media-libs/speex-1.2_rc1 )
+ xosd? ( x11-libs/xosd )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ tc-export CC
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable gsm) \
+ $(use_enable speex) \
+ $(use_enable opus) \
+ $(use_enable xosd) \
+ $(use_enable g15) \
+ $(use_enable espeak) \
+ $(use_with pulseaudio) \
+ $(use_with alsa) \
+ $(use_with oss)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/media-sound/mangler/metadata.xml b/media-sound/mangler/metadata.xml
new file mode 100644
index 000000000000..07e68d257297
--- /dev/null
+++ b/media-sound/mangler/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="espeak">Text to speech engine</flag>
+ <flag name="g15">Logitech g15 lcd support</flag>
+ <flag name="opus">Codec specialized for speech over the internet</flag>
+ </use>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>