summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-29 17:22:43 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-29 20:27:32 -0400
commit35178d5ceee311f46117a41cb92da8ddc02cb188 (patch)
treedb5ccb31ab79d6534b860a760d8668deb4947ca4 /media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
parentdev-vcs/git: Bump to v2.16.4 & v2.17.1 (diff)
downloadgentoo-35178d5ceee311f46117a41cb92da8ddc02cb188.tar.gz
gentoo-35178d5ceee311f46117a41cb92da8ddc02cb188.tar.bz2
gentoo-35178d5ceee311f46117a41cb92da8ddc02cb188.zip
media-sound/mp32ogg: bump EAPI and drop eutils
Upstream is dead, but the package is still mirrored by Gentoo. Unable to rename the source file. Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8641
Diffstat (limited to 'media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild')
-rw-r--r--media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild b/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
index 72c5e39e14aa..92d9ea2f2c79 100644
--- a/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
+++ b/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="A perl script to convert MP3 files to Ogg Vorbis files"
HOMEPAGE="http://faceprint.com/code/"
@@ -21,17 +20,17 @@ DEPEND=""
S=${WORKDIR}
-src_unpack() {
- cp -f "${DISTDIR}"/${PN} "${WORKDIR}" || die
-}
+PATCHES=(
+ "${FILESDIR}/${P}-r4-mpg321.patch"
+ "${FILESDIR}/${P}-r4-quality.patch"\
+ "${FILESDIR}/${P}-r5-german_umlaut.patch"
+ "${FILESDIR}/${P}-r6-force-filename-stringification.patch"
+)
-src_prepare() {
- epatch "${FILESDIR}"/${P}-r4-mpg321.patch \
- "${FILESDIR}"/${P}-r4-quality.patch \
- "${FILESDIR}"/${P}-r5-german_umlaut.patch \
- "${FILESDIR}"/${P}-r6-force-filename-stringification.patch
+src_unpack() {
+ cp -f "${DISTDIR}"/${PN} "${WORKDIR}" || die "Copying sources failed"
}
src_install() {
- dobin mp32ogg || die
+ dobin mp32ogg
}