summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mp3c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mp3c')
-rw-r--r--media-sound/mp3c/Manifest1
-rw-r--r--media-sound/mp3c/files/mp3c-buffer.patch11
-rw-r--r--media-sound/mp3c/metadata.xml5
-rw-r--r--media-sound/mp3c/mp3c-0.31-r1.ebuild42
4 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/mp3c/Manifest b/media-sound/mp3c/Manifest
new file mode 100644
index 000000000000..f5493fd1e5fc
--- /dev/null
+++ b/media-sound/mp3c/Manifest
@@ -0,0 +1 @@
+DIST mp3c-0.31.tar.bz2 351015 RMD160 a8de900b2f9a699b247cefed2cd2fe73b86f9da5 SHA1 af67dea78b3ccef08b091e54499f1ec25bfb7393 SHA256 5a98855ff180e5c3a7805866c04e50204dd2336784b1bc7a24445fa984e878bb
diff --git a/media-sound/mp3c/files/mp3c-buffer.patch b/media-sound/mp3c/files/mp3c-buffer.patch
new file mode 100644
index 000000000000..8dc79c84b1de
--- /dev/null
+++ b/media-sound/mp3c/files/mp3c-buffer.patch
@@ -0,0 +1,11 @@
+--- mp3c-0.31/src/options.c.old 2006-11-10 08:24:15.000000000 +0100
++++ mp3c-0.31/src/options.c 2006-11-10 08:24:27.000000000 +0100
+@@ -1117,7 +1117,7 @@
+ field_select_typ *new, *anchor;
+ song_typ song_chg_fields, *song_curr;
+ char *pointer;
+- char mini_str[35];
++ char mini_str[200];
+ int i;
+ BOOL use_old;
+ BOOL loaded_def;
diff --git a/media-sound/mp3c/metadata.xml b/media-sound/mp3c/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/mp3c/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/mp3c/mp3c-0.31-r1.ebuild b/media-sound/mp3c/mp3c-0.31-r1.ebuild
new file mode 100644
index 000000000000..1115d67dbcb9
--- /dev/null
+++ b/media-sound/mp3c/mp3c-0.31-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE="mp3 vorbis"
+
+DESCRIPTION="console based mp3 ripper, with cddb support"
+HOMEPAGE="http://wspse.de/WSPse/Linux-MP3c.php3"
+SRC_URI="ftp://ftp.wspse.de/pub/linux/wspse/${P}.tar.bz2"
+
+RDEPEND="mp3? ( media-sound/lame
+ >=media-sound/mp3info-0.8.4-r1 )
+ virtual/cdrtools
+ vorbis? ( media-sound/vorbis-tools )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc sparc x86"
+
+LANGS="de es it pl pt"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-buffer.patch"
+}
+
+src_compile() {
+ econf $(use_enable vorbis oggdefaults) || die "econf failed !"
+ emake || die "emake failed!"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS *README BUGS CDDB_HOWTO ChangeLog FAQ NEWS OTHERS TODO
+}