summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-03 05:11:12 +0000
committerSam James <sam@gentoo.org>2020-08-03 05:12:45 +0000
commit36f8689f7903548f5d89827a6e7bdf70a9882cee (patch)
tree21e4b3ea2579793c3b65c587a166abcbf7864d65 /media-sound/mp3gain/mp3gain-1.6.2.ebuild
parentdev-ruby/tty-screen: add 0.8.1 (diff)
downloadgentoo-36f8689f7903548f5d89827a6e7bdf70a9882cee.tar.gz
gentoo-36f8689f7903548f5d89827a6e7bdf70a9882cee.tar.bz2
gentoo-36f8689f7903548f5d89827a6e7bdf70a9882cee.zip
media-sound/mp3gain: bump to 1.6.2 (+ CVE patch)
Bump to 1.6.2, which includes an upstreamed patch for a previous CVE, and include openSUSE's patch for CVE-2019-18359 (and others). Bug: https://bugs.gentoo.org/717940 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/mp3gain/mp3gain-1.6.2.ebuild')
-rw-r--r--media-sound/mp3gain/mp3gain-1.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mp3gain/mp3gain-1.6.2.ebuild b/media-sound/mp3gain/mp3gain-1.6.2.ebuild
new file mode 100644
index 000000000000..44bb50545685
--- /dev/null
+++ b/media-sound/mp3gain/mp3gain-1.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P//./_}"
+
+DESCRIPTION="A program to analyze and adjust MP3 files to same volume"
+HOMEPAGE="http://mp3gain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+S="${WORKDIR}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="media-sound/mpg123"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.2-CVE-2019-18359-plus.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin mp3gain
+}