summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-09-16 18:36:07 +0200
committerChristoph Mende <angelos@gentoo.org>2015-09-16 18:36:07 +0200
commit93595e17e0fa770f01ad44f9c4ffb44cdfeb7aa0 (patch)
treeecdf447c3a1b416402c43aedcef0174f3f1d5deb /media-sound/mpc/mpc-0.27.ebuild
parentmedia-sound/mpd: remove old versions (diff)
downloadgentoo-93595e17e0fa770f01ad44f9c4ffb44cdfeb7aa0.tar.gz
gentoo-93595e17e0fa770f01ad44f9c4ffb44cdfeb7aa0.tar.bz2
gentoo-93595e17e0fa770f01ad44f9c4ffb44cdfeb7aa0.zip
media-sound/mpc: version bump to 0.27
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/mpc/mpc-0.27.ebuild')
-rw-r--r--media-sound/mpc/mpc-0.27.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mpc/mpc-0.27.ebuild b/media-sound/mpc/mpc-0.27.ebuild
new file mode 100644
index 000000000000..b742f1ef65a2
--- /dev/null
+++ b/media-sound/mpc/mpc-0.27.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit bash-completion-r1
+
+DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="http://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="iconv"
+
+RDEPEND=">=media-libs/libmpdclient-2.2
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README doc/mpd-m3u-handler.sh doc/mppledit
+ doc/mpd-pls-handler.sh )
+
+src_configure() {
+ econf $(use_enable iconv) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ newbashcomp doc/mpc-completion.bash ${PN}
+}