summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mpc')
-rw-r--r--media-sound/mpc/Manifest2
-rw-r--r--media-sound/mpc/metadata.xml9
-rw-r--r--media-sound/mpc/mpc-0.25.ebuild33
-rw-r--r--media-sound/mpc/mpc-0.26.ebuild33
4 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/mpc/Manifest b/media-sound/mpc/Manifest
new file mode 100644
index 000000000000..2e85306ef330
--- /dev/null
+++ b/media-sound/mpc/Manifest
@@ -0,0 +1,2 @@
+DIST mpc-0.25.tar.xz 100880 SHA256 70cfa4f734a275a3c76df481ec5222872362ed8f58a4175459cae65d66acaf24 SHA512 7752dd35027b6075d96a27808556af8b2b6e1ac5bb8069515f5baadf25ff31d46409749163634c668da132428b9686ba01a04051f4d41d4cd5e782e57a07b2cb WHIRLPOOL c73eefd8481a1c7cc43840b514c5b571fe204c8e51096562d3a797416f602ce5352491736a8f477b1924483165e90064bbdcb352e5c6476749fb20ea957d1073
+DIST mpc-0.26.tar.xz 105432 SHA256 20735f7173cce56bec50c1d8b4633751052dc68365b29a6113206dc1cdc6e242 SHA512 099d4970418fa848290864ff475801cc9e0aada3f8c11809a0254b9645229d1564e58b746e7e6a327860df72e4d645de06eb7aa9b3cc5f3b7a42331c4aa7192e WHIRLPOOL 53d9e9d9546727b4b8dacd716e95ed77c199aa6b99104d67a0d3ee8e98d4e3a6aa2544552c9e17da6183d4fe50e8baa1c0d2800b946338d86f7d69be6fc3ca21
diff --git a/media-sound/mpc/metadata.xml b/media-sound/mpc/metadata.xml
new file mode 100644
index 000000000000..f939777e6a35
--- /dev/null
+++ b/media-sound/mpc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-sound/mpc/mpc-0.25.ebuild b/media-sound/mpc/mpc-0.25.ebuild
new file mode 100644
index 000000000000..b5ff7a55e298
--- /dev/null
+++ b/media-sound/mpc/mpc-0.25.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit bash-completion-r1
+
+DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="http://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="iconv"
+
+RDEPEND=">=media-libs/libmpdclient-2.2
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README doc/mpd-m3u-handler.sh doc/mppledit
+ doc/mpd-pls-handler.sh )
+
+src_configure() {
+ econf $(use_enable iconv) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ newbashcomp doc/mpc-completion.bash ${PN}
+}
diff --git a/media-sound/mpc/mpc-0.26.ebuild b/media-sound/mpc/mpc-0.26.ebuild
new file mode 100644
index 000000000000..b742f1ef65a2
--- /dev/null
+++ b/media-sound/mpc/mpc-0.26.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit bash-completion-r1
+
+DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="http://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="iconv"
+
+RDEPEND=">=media-libs/libmpdclient-2.2
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README doc/mpd-m3u-handler.sh doc/mppledit
+ doc/mpd-pls-handler.sh )
+
+src_configure() {
+ econf $(use_enable iconv) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ newbashcomp doc/mpc-completion.bash ${PN}
+}