summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-09-07 20:29:18 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-09-07 20:29:44 +0300
commit88a98adeff58dfc908aa250cfc08e16ebb4a505b (patch)
treea50e413e29c8e205b63e53f8170e7ac55500a089 /media-sound/mpc
parentmedia-libs/mesa: Version bump to 18.1.18 (diff)
downloadgentoo-88a98adeff58dfc908aa250cfc08e16ebb4a505b.tar.gz
gentoo-88a98adeff58dfc908aa250cfc08e16ebb4a505b.tar.bz2
gentoo-88a98adeff58dfc908aa250cfc08e16ebb4a505b.zip
media-sound/mpc: Version bump
- migrate to meson - add test suit Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-sound/mpc')
-rw-r--r--media-sound/mpc/Manifest1
-rw-r--r--media-sound/mpc/mpc-0.30.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/mpc/Manifest b/media-sound/mpc/Manifest
index b767286b884c..a6f5fb1e1ac3 100644
--- a/media-sound/mpc/Manifest
+++ b/media-sound/mpc/Manifest
@@ -1 +1,2 @@
DIST mpc-0.28.tar.xz 109172 BLAKE2B de0155bd1d723c0affc02055fe8923a174d6a393e431bd71399e0c0833dda5488569fa90bbdb0c650a367bbc0c384d91215bc0997f013a372c0eae015d7acc27 SHA512 1d0c96c3c7cee2eac2d3cf25f09d74b5807b8ea56ff7dfc033b8fa690fd4d42de726a641e4f2552550d8a1c1b2840575aec5c595166ca5ae5776fcc93c8fb7cf
+DIST mpc-0.30.tar.xz 41968 BLAKE2B e7d1156f4fe933c360196a1fdaadeb7b51f12b3c6d7bd2f98f80359485acb9d55ea7afb98c82696078b325ab3662bf33b20653d5e0edf0f52c64624c679dd0b6 SHA512 72d6f742de87ca1a9a09c73987786fa7c93b2829242135b210a9a2269e0319ba9e37367dae1043461ea870087faf5c349425025ce6c02aa9dd513ae90cbe8221
diff --git a/media-sound/mpc/mpc-0.30.ebuild b/media-sound/mpc/mpc-0.30.ebuild
new file mode 100644
index 000000000000..c21d944d3fbd
--- /dev/null
+++ b/media-sound/mpc/mpc-0.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 meson
+
+DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
+HOMEPAGE="https://www.musicpd.org"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="iconv test"
+
+RDEPEND="media-libs/libmpdclient
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+src_configure() {
+ local emesonargs=(
+ -Dtest=$(usex iconv true false)
+ -Diconv=$(usex test true false)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newbashcomp contrib/mpc-completion.bash mpc
+}