summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-02 15:59:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-02 16:00:49 +0100
commit206df22c22de4815799625ce979f40096929df75 (patch)
tree88efd8fa54fa91731e0a4a4da3a12eff77c0b74b /media-sound/pamix
parentdev-python/appdirs: Clean old up (diff)
downloadgentoo-206df22c22de4815799625ce979f40096929df75.tar.gz
gentoo-206df22c22de4815799625ce979f40096929df75.tar.bz2
gentoo-206df22c22de4815799625ce979f40096929df75.zip
media-sound/pamix: Bump to version 1.6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound/pamix')
-rw-r--r--media-sound/pamix/Manifest1
-rw-r--r--media-sound/pamix/pamix-1.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/pamix/Manifest b/media-sound/pamix/Manifest
index 4aa70854cf89..acf5c3b7744f 100644
--- a/media-sound/pamix/Manifest
+++ b/media-sound/pamix/Manifest
@@ -1,2 +1,3 @@
DIST pamix-1.4.1.tar.gz 15900 BLAKE2B 127467ae6cf2d380f78ab2ccd0e990a11ad1747adfe82411f05ba08403ebfc3d91ab10f931dfe46451755a350a830643abbf0165744eefa57ee4e3ed25f8f426 SHA512 2b33f384760f7706a10879ba51f027fd47e46f53c7a784feae0adf18f0badd7826a19a6ed75886a0c78afa115ca0725ddf7e319e55565f5b05081578310512d2
DIST pamix-1.5.tar.gz 16902 BLAKE2B 4f7612cb870f84110b8cc31a061afecb7c2aeb8d073887cde671bbaf8702db83b8cfe4e7b06e9260c6925c4334c1cb46175612f87d4ed625181179f615b6e954 SHA512 51516664c5f5d8d0c70565c5cdd7a91e7d40c83a49d75ca76c38286d937a737da28f9070e9d0185545d8e74999894e3afa9f1d2f8c22658f83af5c1c161f7938
+DIST pamix-1.6.tar.gz 18552 BLAKE2B 35cc2844cf0d5824c961a226f1b857b3ac070dc5c4fc802a9aa21a3317f9afdc42fb87e18d9e9a61276ace66a93d42c256e7811e946e3f9fba19f645ab8f07ef SHA512 53f3a892b41418cdbfff28d29636997e777ab9e1042f002e1df47735941e5a34f0391866939c539594d22f0b3f0cbd1ad5342dc5663d816e12354ae9e744d5f8
diff --git a/media-sound/pamix/pamix-1.6.ebuild b/media-sound/pamix/pamix-1.6.ebuild
new file mode 100644
index 000000000000..19febfb88f4a
--- /dev/null
+++ b/media-sound/pamix/pamix-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SCM=""
+[[ "${PV}" == 9999 ]] && SCM="git-r3"
+inherit cmake-utils ${SCM}
+unset SCM
+
+DESCRIPTION="A PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+LICENSE="MIT"
+SLOT="0"
+IUSE="+unicode"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/patroclos/PAmix.git"
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+RDEPEND="media-sound/pulseaudio
+ sys-libs/ncurses:0=[unicode?]"
+DEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # ugly hackaround for split tinfo ncurses libs
+ sed '/link_libraries.*ncurses/s@\(")\)@" "tinfo\1@' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_UNICODE="$(usex unicode)"
+ )
+ cmake-utils_src_configure
+}