summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 20:58:09 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:32 +0200
commitce6e2c37f0488256ee7c74462978634b3d16a64c (patch)
treecd7eb8b93214a70dbbc616b2126a9d14a144f17f /media-sound/pavucontrol-qt
parentmedia-gfx/lximage-qt: add version 0.15.0 (diff)
downloadgentoo-ce6e2c37f0488256ee7c74462978634b3d16a64c.tar.gz
gentoo-ce6e2c37f0488256ee7c74462978634b3d16a64c.tar.bz2
gentoo-ce6e2c37f0488256ee7c74462978634b3d16a64c.zip
media-sound/pavucontrol-qt: add version 0.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/pavucontrol-qt')
-rw-r--r--media-sound/pavucontrol-qt/Manifest1
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/Manifest b/media-sound/pavucontrol-qt/Manifest
index 50deec338c5d..84b6f14b82fd 100644
--- a/media-sound/pavucontrol-qt/Manifest
+++ b/media-sound/pavucontrol-qt/Manifest
@@ -1 +1,2 @@
DIST pavucontrol-qt-0.14.1.tar.xz 94948 BLAKE2B e0bbbaa2410220c0e34ff77cb84c783ba682587311eaf20eca286a142e122827b6294e9d0409f2ea5b18d80c06d822bbaed49d60d1402a4a97b7f7210ee2cacd SHA512 55a8bceb31e07ceac7ab1fbb5f20101dfb087e58578039a238677e77f858e0564dca46efee2d5513a247c0be474f24d31e3afa9cf3cea0734feb0e56c33d5494
+DIST pavucontrol-qt-0.15.0.tar.xz 97480 BLAKE2B 183c3cbbe87b6867bb116041d41dd29f5ba72156e9078a4f09e5ffcbd3e123f6511cb06c99ce3cc8ce243a0551b132438bad7b14ae759cc775974c2ad3388bf3 SHA512 c77b0c7403c24df7839598aa46a6076e9ce84a102866a8917c6b8535f1a2b15baacd63e9ddf6bf0b7e914e7c681f0e10bbe378a641bc71144c1b22bc918e4600
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild
new file mode 100644
index 000000000000..21b7b2ce6716
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt GUI Pulseaudio Mixer"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"