summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-07-06 18:11:31 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-07-06 18:11:31 -0700
commit7ae1c68c69808362b6368eec0387907fc3bb748b (patch)
treec09e2d7da406c6331a7c420f4355cfbae5b01923 /media-sound/pithos/pithos-1.1.2.ebuild
parentdev-python/tinycss2: Initial commit (diff)
downloadgentoo-7ae1c68c69808362b6368eec0387907fc3bb748b.tar.gz
gentoo-7ae1c68c69808362b6368eec0387907fc3bb748b.tar.bz2
gentoo-7ae1c68c69808362b6368eec0387907fc3bb748b.zip
media-sound/pithos: Version bump to 1.1.2
Gentoo-Bug: 571708 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-sound/pithos/pithos-1.1.2.ebuild')
-rw-r--r--media-sound/pithos/pithos-1.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/pithos/pithos-1.1.2.ebuild b/media-sound/pithos/pithos-1.1.2.ebuild
new file mode 100644
index 000000000000..0a651a74e28c
--- /dev/null
+++ b/media-sound/pithos/pithos-1.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=(python3_4)
+inherit eutils distutils-r1
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/pithos/pithos.git
+ https://github.com/pithos/pithos.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="http://pithos.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify appindicator +keybinder"
+
+RDEPEND="
+ dev-python/pylast[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12[${PYTHON_USEDEP}]
+ x11-libs/pango[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ >=x11-libs/gtk+-3.14:3[introspection]
+ x11-themes/gnome-icon-theme-symbolic
+ libnotify? ( x11-libs/libnotify[introspection] )
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}