summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-09 10:03:32 +0000
committerSam James <sam@gentoo.org>2021-01-09 10:36:03 +0000
commit7d295a484f9437407d30a6e3bdb7d5b2a1d5adba (patch)
treeb0365625f2a2a04a2604ada4ef9ea97da6b6d46d /media-sound/pms/pms-9999.ebuild
parentmedia-sound/shnflacverify: MissingUnpackerDep, eutils -> edos2unix (diff)
downloadgentoo-7d295a484f9437407d30a6e3bdb7d5b2a1d5adba.tar.gz
gentoo-7d295a484f9437407d30a6e3bdb7d5b2a1d5adba.tar.bz2
gentoo-7d295a484f9437407d30a6e3bdb7d5b2a1d5adba.zip
media-sound/pms: port to EAPI 7
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pms/pms-9999.ebuild')
-rw-r--r--media-sound/pms/pms-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
index 2a0de1e38b9c..4260a7d72b3a 100644
--- a/media-sound/pms/pms-9999.ebuild
+++ b/media-sound/pms/pms-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake git-r3
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
HOMEPAGE="https://ambientsound.github.io/pms"
@@ -16,15 +16,15 @@ SLOT="0"
KEYWORDS=""
IUSE="+regex doc"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/pandoc )
+"
RDEPEND="
sys-libs/ncurses:0=[unicode]
media-libs/libmpdclient
"
-DEPEND="
- virtual/pkgconfig
- doc? ( app-text/pandoc )
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
@@ -32,5 +32,5 @@ src_configure() {
-DENABLE_REGEX=$(usex regex)
)
- cmake-utils_src_configure
+ cmake_src_configure
}