summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-08-16 20:12:39 +0300
committerKristian Fiskerstrand <k_f@gentoo.org>2016-08-25 21:06:35 +0200
commit1a0a1691f6f70cad55b538de0a7f947da297f822 (patch)
tree0068ae32967733e59b6ea795e1624f38325b4043 /media-sound/pms
parentapp-mobilephone/dfu-util: version bump to 0.9 (diff)
downloadgentoo-1a0a1691f6f70cad55b538de0a7f947da297f822.tar.gz
gentoo-1a0a1691f6f70cad55b538de0a7f947da297f822.tar.bz2
gentoo-1a0a1691f6f70cad55b538de0a7f947da297f822.zip
media-sound/pms: revbump to 0.42-r2
EAPI bump to 6 fixed bug #526530 (build with ncurses[tinfo]) fixed bug #351996 (a buffer overflow) updated HOMEPAGE, SRC_URI and the year in the header
Diffstat (limited to 'media-sound/pms')
-rw-r--r--media-sound/pms/Manifest1
-rw-r--r--media-sound/pms/pms-0.42-r2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/pms/Manifest b/media-sound/pms/Manifest
index 0517e1b6fa74..7cbc4943c78c 100644
--- a/media-sound/pms/Manifest
+++ b/media-sound/pms/Manifest
@@ -1 +1,2 @@
DIST pms-0.42.tar.bz2 196053 SHA256 96bf942b08cba10ee891a63eeccad307fd082ef3bd20be879f189e1959e775a6 SHA512 34fea13f524154455d9a44eb5c885ae3a555adc5e495234c0e720c7351b0e9169226cede08b65eb8236d6b0f35eaeae4968baa374dfd4f53c6cc164cb669ab0a WHIRLPOOL 45a0bb0322541cad6dffb14bb28c1156ce85be7ced57cc7a8dcc12d6b3f298d811f564b522d0110eeceb9fe697bf402541384d611b94fb211bda2181e68b1d1f
+DIST pms-0.42.tar.gz 676147 SHA256 e0b57fb02edee153fcec43adcf88df2f15b36ceed446f01645cd770195c8eedc SHA512 2cfda707f17415b2e8207a0c9add83b652247c42680e478029a2c42dc0bc7987e1cb1dce844163446a783a046a43260e3d5d0e1a1a35a02b69b2c2c0d2fadfcf WHIRLPOOL 6bd5cfd38fe7b37be12c045c40cbcbebbb3af39f998a9e1210152c7f247366e5257bf2a919f83a76a181655ff7a0522e410c7d518db677db524a5a34b7feda8c
diff --git a/media-sound/pms/pms-0.42-r2.ebuild b/media-sound/pms/pms-0.42-r2.ebuild
new file mode 100644
index 000000000000..d1f97298c64e
--- /dev/null
+++ b/media-sound/pms/pms-0.42-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="https://ambientsound.github.io/pms/"
+SRC_URI="https://github.com/ambientsound/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ dev-libs/glib:2
+ regex? ( dev-libs/boost:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # bug #424717
+ sed -i -e "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die 'sed on Makefile.am failed'
+
+ # Compatibility with automake 1.14
+ sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror/subdir-objects/' configure.ac || die 'sed on configure.ac failed'
+
+ # bug #351995
+ sed -i -e '394s/BUFFER/ERRORSTR/' src/libmpdclient.c || die 'sed on libmpdclient.c failed'
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ # fixes build with ncurses[tinfo], bug #526530
+ append-cflags $(pkg-config --cflags ncursesw)
+ append-libs $(pkg-config --libs ncursesw)
+
+ econf \
+ $(use_enable regex)
+}