summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-02 18:06:37 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-02 18:10:35 +0200
commit4a67da4a5f498c7eba06a7d09bd66fc4de80e5df (patch)
tree43b82bd955e4e63aaad96ec4ccee50cef3982579 /media-sound/pnmixer
parentapp-emulation/libvirt: fix sys-libs/ncurses slot warnings (diff)
downloadgentoo-4a67da4a5f498c7eba06a7d09bd66fc4de80e5df.tar.gz
gentoo-4a67da4a5f498c7eba06a7d09bd66fc4de80e5df.tar.bz2
gentoo-4a67da4a5f498c7eba06a7d09bd66fc4de80e5df.zip
media-sound/pnmixer: version bump to 0.6
Diffstat (limited to 'media-sound/pnmixer')
-rw-r--r--media-sound/pnmixer/Manifest1
-rw-r--r--media-sound/pnmixer/pnmixer-0.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/pnmixer/Manifest b/media-sound/pnmixer/Manifest
index 9c78452c3816..f7440447bfdb 100644
--- a/media-sound/pnmixer/Manifest
+++ b/media-sound/pnmixer/Manifest
@@ -1,2 +1,3 @@
+DIST pnmixer-0.6.tar.gz 198551 SHA256 e70faffcc56bec315f23f66dff85dd335627fc3219d37f1583d16e3383811b61 SHA512 89327628edfbab4e62ba80746f2299a5b418110a85d3fea34f1b16af49c97b4cbea7b44a547ac7ab025ff0d8f6b3c1b5eaf07cc69a385b363a57def30a4d0d93 WHIRLPOOL 91c6cf212cc1b06497a720c7c2bb9ddaf7cd9aeb10ab135afaa86ca3085c1fa37b92fb5038cdfa13a2638ae3db7bdd838507922511c984297dc2aebef4b4c0c8
DIST pnmixer-0.6_pre20111213.tar.xz 131328 SHA256 aa42180145aa56639440168935a8b16c576e6e49db0bbe2955b79a890437f013 SHA512 967a685593256f9f2e8ab2ef955a91a03c3710d96956087ac55301d5232e6f01897efbb064bd6dc1804836af1b66c038cb3d04203043462de5246e4f14dd37c4 WHIRLPOOL 1fe36a5ea212447212bbd9b6b4efee22e1f75fbb0f2c0548447c0987664d94524e306e2942f6e96c6f10cf6bf15abc35df6b7953d63ef8ec2241eef3d627c16d
DIST pnmixer-0.6_rc3.tar.gz 199559 SHA256 095d467730f87b0017baa1949f74b9d9cda5cd8901ef4e503f0d2cf523f2d3a2 SHA512 d45e08b63ba6b7c108c92cf7e5bb54bf9133e6cd8d44961e781a55a111f886a43340cd106126c2da61f37faa23dc0bdc1fabda0ce69ae55aae4becc616dfd287 WHIRLPOOL 7066e408b842b75b498e8b24e4a0bcd11ba3314089a2cc56f0a0cc2569fc7a1f969c885da044645946c1c0af20fe4599d19057d5da2afde68320a8ea8d35bc4d
diff --git a/media-sound/pnmixer/pnmixer-0.6.ebuild b/media-sound/pnmixer/pnmixer-0.6.ebuild
new file mode 100644
index 000000000000..6ed4fb6685dd
--- /dev/null
+++ b/media-sound/pnmixer/pnmixer-0.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_LIBTOOL=none
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Volume mixer for the system tray"
+HOMEPAGE="https://github.com/nicklan/pnmixer"
+SRC_URI="https://github.com/nicklan/pnmixer/archive/v${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug libnotify"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/alsa-lib
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_rc/-rc}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ --enable-minimal-flags \
+ --with-gtk3
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}