summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-03 09:18:26 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-03 09:20:16 +0200
commit7cb5feb7c8fb905b24264d9ae6ca2f183481c3c7 (patch)
tree5af7f2f9f6fe292a97a45b4d627a8ed4fe569aaf /media-sound/pulseaudio-ctl/pulseaudio-ctl-1.66.ebuild
parentwww-servers/uwsgi: add ruby26 (diff)
downloadgentoo-7cb5feb7c8fb905b24264d9ae6ca2f183481c3c7.tar.gz
gentoo-7cb5feb7c8fb905b24264d9ae6ca2f183481c3c7.tar.bz2
gentoo-7cb5feb7c8fb905b24264d9ae6ca2f183481c3c7.zip
media-sound/pulseaudio-ctl: New package
CLI tool to control volume in pulseaudio. Very handy for keybindings. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio-ctl/pulseaudio-ctl-1.66.ebuild')
-rw-r--r--media-sound/pulseaudio-ctl/pulseaudio-ctl-1.66.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.66.ebuild b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.66.ebuild
new file mode 100644
index 000000000000..56d2816a5cb6
--- /dev/null
+++ b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.66.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="CLI utility to control PulseAudio volume"
+HOMEPAGE="https://github.com/graysky2/pulseaudio-ctl"
+SRC_URI="https://github.com/graysky2/pulseaudio-ctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Optional runtime deps: dbus-send for KDE OSD, notify-send for libnotify
+# in both cases they should be already present if DE supports them
+RDEPEND="media-sound/pulseaudio"
+
+src_install() {
+ # install-man target compresses manpage
+ emake install-bin PREFIX="${EPREFIX}/usr" DESTDIR="${D}"
+ doman doc/pulseaudio-ctl.1
+}