summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-06-07 09:12:39 +0300
committerSam James <sam@gentoo.org>2022-06-10 07:58:01 +0100
commit1dce7fa0f5c422de63ba13da2d3dd287f8d0206a (patch)
tree5e74f015b2ce8d75324d6560131332618f97cf99 /media-sound/pulseaudio-daemon
parentmedia-sound/pulseaudio: Drop USE native-backend (diff)
downloadgentoo-1dce7fa0f5c422de63ba13da2d3dd287f8d0206a.tar.gz
gentoo-1dce7fa0f5c422de63ba13da2d3dd287f8d0206a.tar.bz2
gentoo-1dce7fa0f5c422de63ba13da2d3dd287f8d0206a.zip
media-sound/pulseaudio-daemon: Drop USE native-backend
Native backend supporting bluetooth HSP HS, HFP HF and HSP AG profiles is now quite stable, unconditionally enable it if USE bluetooth and drop USE native-backend from package. If user wants to selectively disable pulseaudio handling of these bluetooth profiles, this can be done via runtime configuration in /etc/pulse/default.pa This is noted in added elog entries. Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25456 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio-daemon')
-rw-r--r--media-sound/pulseaudio-daemon/metadata.xml5
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0-r1.ebuild (renamed from media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild)20
2 files changed, 17 insertions, 8 deletions
diff --git a/media-sound/pulseaudio-daemon/metadata.xml b/media-sound/pulseaudio-daemon/metadata.xml
index d44e1ed3057b..5d81f9170193 100644
--- a/media-sound/pulseaudio-daemon/metadata.xml
+++ b/media-sound/pulseaudio-daemon/metadata.xml
@@ -68,11 +68,8 @@
ConsoleKit.
</flag>
<flag name="valgrind">Compile in valgrind memory hints</flag>
- <flag name="native-headset">
- Build with native HSP backend for bluez 5.
- </flag>
<flag name="ofono-headset">
- Build with oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
+ Build with optional oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
</flag>
<flag name="gstreamer">
Build GStreamer-based RTP protocol module which supports more advanced RTP features like OPUS payload encoding.
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0-r1.ebuild
index b8c4907403b4..776d8793399f 100644
--- a/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0.ebuild
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0-r1.ebuild
@@ -33,7 +33,7 @@ SLOT="0"
# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer fftw +gdbm +glib gstreamer gtk ipv6 jack ldac lirc
-native-headset ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
+ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
RESTRICT="!test? ( test )"
@@ -47,7 +47,6 @@ REQUIRED_USE="
bluetooth? ( dbus )
equalizer? ( dbus )
ldac? ( bluetooth )
- native-headset? ( bluetooth )
ofono-headset? ( bluetooth )
udev? ( || ( alsa oss ) )
zeroconf? ( dbus )
@@ -207,7 +206,7 @@ src_configure() {
$(meson_feature zeroconf avahi)
$(meson_feature bluetooth bluez5)
-Dbluez5-gstreamer=${enable_bluez5_gstreamer}
- $(meson_use native-headset bluez5-native-headset)
+ $(meson_use bluetooth bluez5-native-headset)
$(meson_use ofono-headset bluez5-ofono-headset)
$(meson_feature dbus)
$(meson_feature elogind)
@@ -329,7 +328,20 @@ pkg_postinst() {
elog ""
fi
- if use native-headset && use ofono-headset; then
+ if use bluetooth; then
+ elog "You have enabled bluetooth USE flag for pulseaudio. Daemon will now handle"
+ elog "bluetooth Headset (HSP HS and HSP AG) and Handsfree (HFP HF) profiles using"
+ elog "native headset backend by default. This can be selectively disabled"
+ elog "via runtime configuration arguments to module-bluetooth-discover"
+ elog "in /etc/pulse/default.pa"
+ elog "To disable HFP HF append enable_native_hfp_hf=false"
+ elog "To disable HSP HS append enable_native_hsp_hs=false"
+ elog "To disable HSP AG append headset=auto or headset=ofono"
+ elog "(note this does NOT require enabling USE ofono)"
+ elog ""
+ fi
+
+ if use ofono-headset; then
elog "You have enabled both native and ofono headset profiles. The runtime decision"
elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
elog ""