summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-11-26 16:56:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-11-26 16:56:54 -0600
commit4a1a8d9365a31ef7868d9f774f7e1f224a90e54e (patch)
treefd9f04307d11a556d9590d45b3ecd44c579f93f7 /media-sound/pulseeffects/pulseeffects-9999.ebuild
parentmedia-plugins/gst-plugins-ladspa: 1.12.3 bup (diff)
downloadgentoo-4a1a8d9365a31ef7868d9f774f7e1f224a90e54e.tar.gz
gentoo-4a1a8d9365a31ef7868d9f774f7e1f224a90e54e.tar.bz2
gentoo-4a1a8d9365a31ef7868d9f774f7e1f224a90e54e.zip
media-sound/pulseeffects: initial add
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-sound/pulseeffects/pulseeffects-9999.ebuild')
-rw-r--r--media-sound/pulseeffects/pulseeffects-9999.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/pulseeffects/pulseeffects-9999.ebuild b/media-sound/pulseeffects/pulseeffects-9999.ebuild
new file mode 100644
index 000000000000..82799b6d8fbb
--- /dev/null
+++ b/media-sound/pulseeffects/pulseeffects-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome2-utils meson python-r1
+
+DESCRIPTION="Limiter, compressor, reverberation, equalizer auto volume effects for Pulseaudio"
+HOMEPAGE="https://github.com/wwmm/pulseeffects"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+ KEYWORDS=""
+else
+ SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ python_targets_python3_4? ( dev-python/configparser )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ media-plugins/swh-plugins
+ >=x11-libs/gtk+-3.18:3
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.18[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.12.0:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-plugins/gst-plugins-ladspa:1.0
+"
+RDEPEND="${DEPEND}
+ media-sound/pulseaudio[equalizer]
+"
+
+pkg_preinst(){
+ gnome2_schemas_savelist
+}
+
+pkg_postinst(){
+ gnome2_gconf_install
+ gnome2_schemas_update
+}
+
+pkg_postrm(){
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+}