summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qastools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qastools')
-rw-r--r--media-sound/qastools/Manifest2
-rw-r--r--media-sound/qastools/metadata.xml8
-rw-r--r--media-sound/qastools/qastools-0.17.2.ebuild45
-rw-r--r--media-sound/qastools/qastools-0.18.1-r1.ebuild43
4 files changed, 98 insertions, 0 deletions
diff --git a/media-sound/qastools/Manifest b/media-sound/qastools/Manifest
new file mode 100644
index 000000000000..799ed6754c0f
--- /dev/null
+++ b/media-sound/qastools/Manifest
@@ -0,0 +1,2 @@
+DIST qastools_0.17.2.tar.xz 202152 SHA256 a5f6a765f1c192b150c5a9fdc2d3490575f7a11a2a53245b731ee513cf22b05a SHA512 81911a93a65e0276460610c6ea96d1c19b5f2965dbabd5650ba03a714832538f9ce0af87abfa1d0c6192d8f25c040028fa325c2a877d47830153bd069719d9b8 WHIRLPOOL 1016d769d1d0617bb4f012b52a0be38cd35f6087eb2f55432b586fc74cce7beda52b8855b24b514cfb9a0d8c0b9ffbf18164ebdb05af0e326884374f1ab4b6dc
+DIST qastools_0.18.1.tar.xz 207752 SHA256 ef94bd3ab8660ff169f2b9a0425b3a415a62e2c5c34427b9ec7af2299dde2dc6 SHA512 011d45bae593514647b6f7af3135467f1a3a203fa85a76d72eb26f766701318131500dd44e00765fcd80addd096fa71e49d1e9a0d00e7bf618ec1037207d584c WHIRLPOOL 294364384a5b9f39b829897aa7932605d61717582538c7893453313911717961943cb0bc340766f9fa6f83e16117bd1378d8bceffd39484b5cd76d6b746872b7
diff --git a/media-sound/qastools/metadata.xml b/media-sound/qastools/metadata.xml
new file mode 100644
index 000000000000..6a60bbd94825
--- /dev/null
+++ b/media-sound/qastools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">qastools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/qastools/qastools-0.17.2.ebuild b/media-sound/qastools/qastools-0.17.2.ebuild
new file mode 100644
index 000000000000..9e12fecead94
--- /dev/null
+++ b/media-sound/qastools/qastools-0.17.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Qt4 GUI ALSA tools: mixer, configuration browser"
+HOMEPAGE="http://xwmw.org/qastools/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="cs de es ru"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="media-libs/alsa-lib
+ >=dev-qt/qtcore-4.6:4
+ >=dev-qt/qtgui-4.6:4
+ >=dev-qt/qtsvg-4.6:4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( CHANGELOG README TODO )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ local lang
+ for lang in ${LANGS} ; do
+ if ! use linguas_${lang} ; then
+ rm i18n/ts/app_${lang}.ts
+ fi
+ done
+}
diff --git a/media-sound/qastools/qastools-0.18.1-r1.ebuild b/media-sound/qastools/qastools-0.18.1-r1.ebuild
new file mode 100644
index 000000000000..e299776ec358
--- /dev/null
+++ b/media-sound/qastools/qastools-0.18.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="cs de es he ru"
+inherit cmake-utils l10n
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Qt4 GUI ALSA tools: mixer, configuration browser"
+HOMEPAGE="http://xwmw.org/qastools/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ >=dev-qt/qtcore-4.6:4
+ >=dev-qt/qtgui-4.6:4
+ >=dev-qt/qtsvg-4.6:4
+ virtual/libudev"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( CHANGELOG README TODO )
+
+rm_loc() {
+ rm i18n/ts/app_${1}.ts || die "removing ${1} locale failed"
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ l10n_for_each_disabled_locale_do rm_loc
+}
+
+src_configure() {
+ local mycmakeargs=( -DSKIP_LICENSE_INSTALL=TRUE )
+ cmake-utils_src_configure
+}