summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-22 01:24:51 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-22 11:37:58 +0200
commit6a4c9fb11e99eb61235a470ec1b03fe9fae69432 (patch)
tree759bfd16f73c06873b66a156c90d2a50176930a0 /media-sound/qjackctl
parentmedia-sound/qjackctl: Fix configure w/ Qt 5.7, drop USE=qt5, EAPI 6 (diff)
downloadgentoo-6a4c9fb11e99eb61235a470ec1b03fe9fae69432.tar.gz
gentoo-6a4c9fb11e99eb61235a470ec1b03fe9fae69432.tar.bz2
gentoo-6a4c9fb11e99eb61235a470ec1b03fe9fae69432.zip
media-sound/qjackctl: Drop old
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2625 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/qjackctl-0.4.3.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.4.3.ebuild b/media-sound/qjackctl/qjackctl-0.4.3.ebuild
deleted file mode 100644
index 744606ed6bc1..000000000000
--- a/media-sound/qjackctl/qjackctl-0.4.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit qmake-utils
-
-DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections"
-HOMEPAGE="http://qjackctl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="alsa dbus debug portaudio +qt5"
-
-RDEPEND="
- virtual/jack
- qt5? ( dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtxml:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5 )
- !qt5? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
- alsa? ( media-libs/alsa-lib )
- dbus? (
- qt5? ( dev-qt/qtdbus:5 )
- !qt5? ( dev-qt/qtdbus:4 )
- )
- portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}
- qt5? ( dev-qt/linguist-tools:5 )"
-
-DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
-
-src_configure() {
- econf \
- $(use_with !qt5 qt4 "$(qt4_get_bindir)/..") \
- $(use_with qt5 qt5 "$(qt5_get_bindir)/..") \
- $(use_enable alsa alsa-seq) \
- $(use_enable dbus) \
- $(use_enable debug) \
- $(use_enable portaudio)
-
- # Emulate what the Makefile does, so that we can get the correct
- # compiler used.
- if use qt5 ; then
- eqmake5 ${PN}.pro -o ${PN}.mak
- else
- eqmake4 ${PN}.pro -o ${PN}.mak
- fi
-}
-
-src_compile() {
- emake -f ${PN}.mak
-}