summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-07-05 08:03:32 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-05 08:03:53 +0200
commitb48e5ec0d890292457a170b5d28a523fa2795664 (patch)
tree9e12eecc09e25f461378bc862e2a7be3c1b6eb99 /media-sound/qjackctl
parentdev-python/iminuit: Bump to 2.7.0 (diff)
downloadgentoo-b48e5ec0d890292457a170b5d28a523fa2795664.tar.gz
gentoo-b48e5ec0d890292457a170b5d28a523fa2795664.tar.bz2
gentoo-b48e5ec0d890292457a170b5d28a523fa2795664.zip
media-sound/qjackctl: bump to 0.9.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/Manifest1
-rw-r--r--media-sound/qjackctl/qjackctl-0.9.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/qjackctl/Manifest b/media-sound/qjackctl/Manifest
index 73c84d596ea6..e29918f540b1 100644
--- a/media-sound/qjackctl/Manifest
+++ b/media-sound/qjackctl/Manifest
@@ -1 +1,2 @@
DIST qjackctl-0.9.3.tar.gz 1093889 BLAKE2B e3fdacd8fb287e56d53c1b4afabf69aae89a9c311c1f056ae0f2c0f2c7e994e320a904d9ddd40efd48ed7b15fd7d90ed6ce07adc0db496d133431b1519c83a86 SHA512 bfe1cbd37ebd92409f5dd7e8a28115b9922bb43ad0f38112b140c8635a33cc49614202b9e4f92d57e58ed83a85767f53b538a7e6b69702b159157868081b3435
+DIST qjackctl-0.9.4.tar.gz 1094914 BLAKE2B 61025ecd6695df877802180a95763e5e9d557bc1d36966454cae2638fc5b5439c1ce64b65cd0193e40fd461575a3223b5ef5132905b7d211b75292dbfd5b7299 SHA512 ce808242d8bacadf4e267bdf75c20b53601f54c8a4eb0b5116653afa7bcdd17e99ac4f878d4ec78844194e13623a804850cf8ea7e12430806caad4fe986115c7
diff --git a/media-sound/qjackctl/qjackctl-0.9.4.ebuild b/media-sound/qjackctl/qjackctl-0.9.4.ebuild
new file mode 100644
index 000000000000..15137741a070
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.9.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="https://qjackctl.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus debug portaudio"
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.1-disable-git.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_SEQ=$(usex alsa 1 0)
+ -DCONFIG_DBUS=$(usex dbus 1 0)
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_PORTAUDIO=$(usex portaudio 1 0)
+ )
+ cmake_src_configure
+}