summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qsampler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qsampler')
-rw-r--r--media-sound/qsampler/Manifest1
-rw-r--r--media-sound/qsampler/metadata.xml8
-rw-r--r--media-sound/qsampler/qsampler-0.2.2_p2345.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/qsampler/Manifest b/media-sound/qsampler/Manifest
new file mode 100644
index 000000000000..485d6b405a77
--- /dev/null
+++ b/media-sound/qsampler/Manifest
@@ -0,0 +1 @@
+DIST qsampler-0.2.2.2345.tar.xz 184892 SHA256 4afaf245b5c7b15ecbf447a26c4930dc5e69c8e70397fa20a54a7a2bdf7b778a
diff --git a/media-sound/qsampler/metadata.xml b/media-sound/qsampler/metadata.xml
new file mode 100644
index 000000000000..6839654ee445
--- /dev/null
+++ b/media-sound/qsampler/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="libgig">Enable libgig support for loading Gigasampler files and DLS (Downloadable Sounds) Level 1/2 files</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/qsampler/qsampler-0.2.2_p2345.ebuild b/media-sound/qsampler/qsampler-0.2.2_p2345.ebuild
new file mode 100644
index 000000000000..99450fd4eede
--- /dev/null
+++ b/media-sound/qsampler/qsampler-0.2.2_p2345.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils qt4-r2
+
+MY_P=${P/_p/.}
+DESCRIPTION="A graphical frontend to the LinuxSampler engine"
+HOMEPAGE="http://qsampler.sourceforge.net"
+SRC_URI="mirror://gentoo/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libgig"
+
+DEPEND="media-libs/alsa-lib
+ >=media-libs/liblscp-0.5.5
+ x11-libs/libX11
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ libgig? ( >=media-libs/libgig-3.2.1 )"
+RDEPEND="${DEPEND}
+ >=media-sound/linuxsampler-0.5"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable libgig)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README TODO
+ doman debian/${PN}.1
+}