summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch')
-rw-r--r--media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch b/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
new file mode 100644
index 000000000000..0558b72c9bf5
--- /dev/null
+++ b/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
@@ -0,0 +1,46 @@
+--- src/cli/Makefile
++++ src/cli/Makefile
+@@ -1,4 +1,4 @@
+-CC = g++
++CXX ?= g++
+ mingw = false
+ WINDRES =
+ RES =
+@@ -27,7 +27,7 @@
+ LINKOBJ = scrobble-cli.o libscrobble.o md5.o ConvertUTF.o mtp.o $(RES)
+ endif
+
+-CFLAGS = -Wall -O2 -g $(INCLUDE) $(CURL_FLAGS) $(MTP_FLAGS)
++CXXFLAGS += -Wall $(INCLUDE) $(CURL_FLAGS) $(MTP_FLAGS)
+
+ .PHONY: all all-before all-after clean clean-custom
+
+@@ -37,22 +37,22 @@
+ rm -f *.o *~ *.d $(BIN) $(BIN).exe
+
+ $(BIN): $(OBJ)
+- $(CC) $(LINKOBJ) -o $(BIN) $(LIBS)
++ $(CXX) $(LDFLAGS) $(LINKOBJ) -o $(BIN) $(LIBS)
+
+ scrobble-cli.o: scrobble-cli.cpp
+- $(CC) -c scrobble-cli.cpp -o scrobble-cli.o $(CFLAGS)
++ $(CXX) -c scrobble-cli.cpp -o scrobble-cli.o $(CXXFLAGS)
+
+ libscrobble.o: ../lib/libscrobble.cpp
+- $(CC) -c ../lib/libscrobble.cpp -o libscrobble.o $(CFLAGS)
++ $(CXX) -c ../lib/libscrobble.cpp -o libscrobble.o $(CXXFLAGS)
+
+ md5.o: ../lib/md5.c
+- $(CC) -c ../lib/md5.c -o md5.o $(CFLAGS)
++ $(CXX) -c ../lib/md5.c -o md5.o $(CXXFLAGS)
+
+ ConvertUTF.o: ../lib/ConvertUTF.c
+- $(CC) -c ../lib/ConvertUTF.c -o ConvertUTF.o $(CFLAGS)
++ $(CXX) -c ../lib/ConvertUTF.c -o ConvertUTF.o $(CXXFLAGS)
+
+ mtp.o: ../lib/mtp-libmtp.cpp
+- $(CC) -c ../lib/mtp-libmtp.cpp -o mtp.o $(CFLAGS)
++ $(CXX) -c ../lib/mtp-libmtp.cpp -o mtp.o $(CXXFLAGS)
+
+ install:
+ install -D -m 755 scrobble-cli -p $(DESTDIR)$(bindir)/scrobble-cli