summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rawrec/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rawrec/files')
-rw-r--r--media-sound/rawrec/files/rawrec-libs.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-sound/rawrec/files/rawrec-libs.patch b/media-sound/rawrec/files/rawrec-libs.patch
new file mode 100644
index 000000000000..c894c5ba692d
--- /dev/null
+++ b/media-sound/rawrec/files/rawrec-libs.patch
@@ -0,0 +1,22 @@
+Index: src/Makefile
+===================================================================
+--- src.orig/Makefile
++++ src/Makefile
+@@ -19,7 +19,7 @@ OPTFLAGS = -O2
+ CFLAGS = $(WARNFLAGS) $(OPTFLAGS) $(DEBUGFLAGS) -DUSEBUFFLOCK \
+ $(FANCY_THREAD_DEFINES) -D_REENTRANT -D_GNU_SOURCE \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+-LDFLAGS = -lm -lpthread
++LIBS = -lm -lpthread
+
+ # The GNU way is just too painful. I'm not writing three tiers of
+ # variables just to get to /usr/local/man/man1. If it starts to seem
+@@ -35,7 +35,7 @@ MAN_DIR = /usr/local/man/man1
+ all: $(PROG) $(ALT_INVOC)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o $(PROG)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG) $(LIBS)
+
+ # Everything is rebuilt if this Makefile (which is hopefully named
+ # "Makefile") or any header changes.