summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rcenter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rcenter')
-rw-r--r--media-sound/rcenter/Manifest1
-rw-r--r--media-sound/rcenter/files/rcenter-0.6.2-makefile.patch16
-rw-r--r--media-sound/rcenter/metadata.xml5
-rw-r--r--media-sound/rcenter/rcenter-0.6.2.ebuild43
4 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/rcenter/Manifest b/media-sound/rcenter/Manifest
new file mode 100644
index 000000000000..5daa7e38bc45
--- /dev/null
+++ b/media-sound/rcenter/Manifest
@@ -0,0 +1 @@
+DIST rcenter-0.6.2.tgz 15053 RMD160 58840cdd8022be16682803e0904e08a817fd00ef SHA1 d587aff9df68e2290c7cf141ff6eaadf7d0358aa SHA256 53b82756e11bc2e4e64242e0fd7f37aa5ceb5179d45b504c598958b9d101a800
diff --git a/media-sound/rcenter/files/rcenter-0.6.2-makefile.patch b/media-sound/rcenter/files/rcenter-0.6.2-makefile.patch
new file mode 100644
index 000000000000..2c5fbd761a83
--- /dev/null
+++ b/media-sound/rcenter/files/rcenter-0.6.2-makefile.patch
@@ -0,0 +1,16 @@
+Index: rcenter-0.6.2/Makefile
+===================================================================
+--- rcenter-0.6.2.orig/Makefile
++++ rcenter-0.6.2/Makefile
+@@ -19,9 +19,9 @@ button.o : button.c
+ main.o : main.c
+
+ rcenter : main.o lowlevel.o handler.o button.o
+- $(CC) $(CFLAGS) -o rcenter $^ -lpthread
++ $(CC) $(LDFLAGS) -o rcenter $^ -lpthread
+
+-projname := $(shell awk '/RCENTER_VERSION/ { print $$3 }' version.h )
++projname := $(shell gawk '/RCENTER_VERSION/ { print $$3 }' version.h )
+
+ install: rcenter
+ install -D rcenter $(PREFIX)/bin/rcenter
diff --git a/media-sound/rcenter/metadata.xml b/media-sound/rcenter/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/rcenter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/rcenter/rcenter-0.6.2.ebuild b/media-sound/rcenter/rcenter-0.6.2.ebuild
new file mode 100644
index 000000000000..4e6bd14b48f7
--- /dev/null
+++ b/media-sound/rcenter/rcenter-0.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="Rcenter - A program to control the EMU10K Remote Control"
+HOMEPAGE="http://rooster.stanford.edu/~ben/projects/rcenter.php"
+SRC_URI="http://rooster.stanford.edu/~ben/projects/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-sparc: emu10k1 doesn't get recognized on sparc hardware
+KEYWORDS="amd64 -sparc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ chmod 755 rcenter
+ dobin rcenter
+ dodir /usr/share/rcenter
+ cp -R config "${D}"/usr/share/rcenter/
+ dodoc HISTORY README
+}
+
+pkg_postinst() {
+ elog "Rcenter Installed - However You need to setup the scripts"
+ elog "for making remote control commands actually work"
+ elog
+ elog "The Skel scripts can be copied from /usr/share/rcenter/config to <user>/.rcenter"
+ elog "Where <user> is a person who will use rcenter"
+ elog "Remeber to use emu-config -i to turn on the remote"
+}