summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rhythmbox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/Manifest1
-rw-r--r--media-sound/rhythmbox/metadata.xml13
-rw-r--r--media-sound/rhythmbox/rhythmbox-3.2.1.ebuild151
3 files changed, 165 insertions, 0 deletions
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
new file mode 100644
index 000000000000..d08f92865ad2
--- /dev/null
+++ b/media-sound/rhythmbox/Manifest
@@ -0,0 +1 @@
+DIST rhythmbox-3.2.1.tar.xz 6833060 SHA256 bf43ca4f5b7531751241f5e67eaba7da6d9748dd827a600eedf9444961537938 SHA512 866d6e4a4a3b5561ac76b38ac87001f20b4cfa4e9ad201060a556eac004c72f834a15368d132c1fa59172d0dbdf73e14f8a2f7ea1f10274a4f7fcd50562e9a34 WHIRLPOOL a4c942245e876766dd9b6fd1ba44b463d6f33d7a568e13c3d76da56045c90c2b34cf43749fa5b243b93d50e566a194753dc9ba6202366c35618aa81cafcebdfc
diff --git a/media-sound/rhythmbox/metadata.xml b/media-sound/rhythmbox/metadata.xml
new file mode 100644
index 000000000000..bb30c380f030
--- /dev/null
+++ b/media-sound/rhythmbox/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>gstreamer</herd>
+ <use>
+ <flag name="daap">Build the local network music sharing plugin which uses the DAAP protocol using <pkg>net-libs/libdmapsharing</pkg></flag>
+ <flag name="html">Use <pkg>net-libs/webkit-gtk</pkg> for detecting and displaying HTML podcast episode descriptions.</flag>
+ <flag name="libsecret">Enable libsecret support to store login credentials</flag>
+ <flag name="zeitgeist">Build the plugin to inject events to <pkg>gnome-extra/zeitgeist</pkg></flag>
+ <flag name="visualizer">Enable support for visualizations using <pkg>media-plugins/gst-plugins-libvisual</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/rhythmbox/rhythmbox-3.2.1.ebuild b/media-sound/rhythmbox/rhythmbox-3.2.1.ebuild
new file mode 100644
index 000000000000..ad1f0db79994
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-3.2.1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome2 python-r1 multilib virtualx
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Rhythmbox"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="cdr daap dbus +libsecret html ipod libnotify lirc mtp nsplugin +python
+test +udev upnp-av visualizer webkit zeitgeist"
+
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+REQUIRED_USE="
+ ipod? ( udev )
+ mtp? ( udev )
+ dbus? ( python )
+ webkit? ( python )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )
+"
+
+# Tests failing for years without upstream caring at all
+# upstream bug #688745
+RESTRICT="test"
+
+# FIXME: double check what to do with fm-radio plugin
+# webkit-gtk-1.10 is needed because it uses gstreamer-1.0
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libxml2-2.7.8:2
+ >=x11-libs/gtk+-3.6:3[X,introspection]
+ >=x11-libs/gdk-pixbuf-2.18:2
+ >=dev-libs/gobject-introspection-0.10
+ >=dev-libs/libpeas-0.7.3[gtk,python?]
+ >=dev-libs/totem-pl-parser-3.2
+ >=net-libs/libsoup-2.34:2.4
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ >=sys-libs/tdb-1.2.6
+ dev-libs/json-glib
+
+ visualizer? (
+ >=media-libs/clutter-1.8:1.0
+ >=media-libs/clutter-gst-1.9.92:2.0
+ >=media-libs/clutter-gtk-1.0:1.0
+ >=x11-libs/mx-1.0.1:1.0
+ media-plugins/gst-plugins-libvisual:1.0 )
+ cdr? ( >=app-cdr/brasero-2.91.90 )
+ daap? (
+ >=net-libs/libdmapsharing-2.9.19:3.0
+ media-plugins/gst-plugins-soup:1.0 )
+ libsecret? ( >=app-crypt/libsecret-0.18 )
+ html? ( >=net-libs/webkit-gtk-1.10:3 )
+ libnotify? ( >=x11-libs/libnotify-0.7.0 )
+ lirc? ( app-misc/lirc )
+ python? ( >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}] )
+ udev? (
+ virtual/libgudev:=
+ ipod? ( >=media-libs/libgpod-0.7.92[udev] )
+ mtp? ( >=media-libs/libmtp-0.3 ) )
+ zeitgeist? ( gnome-extra/zeitgeist )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-soup:1.0
+ media-plugins/gst-plugins-libmms:1.0
+ || (
+ media-plugins/gst-plugins-cdparanoia:1.0
+ media-plugins/gst-plugins-cdio:1.0 )
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ x11-themes/gnome-icon-theme-symbolic
+ upnp-av? (
+ >=media-libs/grilo-0.2:0.2
+ >=media-plugins/grilo-plugins-0.2:0.2[upnp-av] )
+ python? (
+ >=dev-libs/libpeas-0.7.3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+
+ dbus? ( sys-apps/dbus )
+ libsecret? ( >=app-crypt/libsecret-0.18[introspection] )
+ webkit? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=net-libs/webkit-gtk-1.10:3[introspection] ) )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.9.1
+ test? ( dev-libs/check )
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS MAINTAINERS.old NEWS README THANKS"
+
+ rm -v lib/rb-marshal.{c,h} || die # upstream bug 737831
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: bug???
+ export GST_INSPECT=/bin/true
+
+ # --enable-vala just installs the sample vala plugin, and the configure
+ # checks are broken, so don't enable it
+ gnome2_src_configure \
+ MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins \
+ VALAC=$(type -P true) \
+ --enable-mmkeys \
+ --disable-more-warnings \
+ --disable-static \
+ --disable-vala \
+ --without-hal \
+ $(use_enable visualizer) \
+ $(use_enable daap) \
+ $(use_enable libnotify) \
+ $(use_enable lirc) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable python) \
+ $(use_enable upnp-av grilo) \
+ $(use_with cdr brasero) \
+ $(use_with html webkit) \
+ $(use_with ipod) \
+ $(use_with libsecret) \
+ $(use_with mtp) \
+ $(use_with udev gudev)
+}
+
+src_test() {
+ unset SESSION_MANAGER
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}